View Issue Details

IDProjectCategoryView StatusLast Update
0001745OpenMPTPlayback Compatibilitypublic2024-02-05 17:46
ReporterSlender Assigned ToSaga Musix  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version11
Product VersionOpenMPT 1.31.04.00 / libopenmpt 0.7.3 (current stable) 
Target VersionOpenMPT 1.31.05.00 / libopenmpt 0.7.4 (upcoming stable)Fixed in VersionOpenMPT 1.31.05.00 / libopenmpt 0.7.4 (upcoming stable) 
Summary0001745: Possible glitch in spx-visionsofthepast.it
Description

I noticed that in the above module, https://api.modarchive.org/downloads.php?moduleid=202241#spx-visionsofthepast.it, starting at around 3:40, some of the lower notes sound filtered in other players such as XMPlay, but it sounds like they might not be getting filtered when played in OpenMPT.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)r20107

Activities

Saga Musix

Saga Musix

2024-02-05 17:37

administrator   ~0005833

It seems like this module has the strange / unusual combination of declaring to be saved with IT 2.15 but using an IT format subset compatible with IT 2.00. I have never seen IT 2.15 writing this combination. Unfortunately OpenMPT checks for the "compatible with" version number rather than the "made with" version number when deciding whether to clear Zxx MIDI macros (filters were introduced in IT 2.14, so a file saved with IT 2.13 containing Zxx commands should not enable any filtering), so in this particular case OpenMPT decides to clear all MIDI macros because the file is compatible with IT 2.00, but it shouldn't do so because the file was made with IT 2.15.

Saga Musix

Saga Musix

2024-02-05 17:46

administrator   ~0005834

Fixed in r20109.

Issue History

Date Modified Username Field Change
2024-02-05 15:12 Slender New Issue
2024-02-05 17:33 Saga Musix Assigned To => Saga Musix
2024-02-05 17:33 Saga Musix Status new => assigned
2024-02-05 17:37 Saga Musix Note Added: 0005833
2024-02-05 17:46 Saga Musix Note Added: 0005834
2024-02-05 17:46 Saga Musix Status assigned => resolved
2024-02-05 17:46 Saga Musix Resolution open => fixed
2024-02-05 17:46 Saga Musix Product Version => OpenMPT 1.31.04.00 / libopenmpt 0.7.3 (current stable)
2024-02-05 17:46 Saga Musix Fixed in Version => OpenMPT 1.31.05.00 / libopenmpt 0.7.4 (upcoming stable)
2024-02-05 17:46 Saga Musix Target Version => OpenMPT 1.31.05.00 / libopenmpt 0.7.4 (upcoming stable)