View Issue Details

IDProjectCategoryView StatusLast Update
0001740OpenMPTlibopenmptpublic2024-01-11 11:54
Reporterdro Assigned ToSaga Musix  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product VersionOpenMPT 1.31.04.00 / libopenmpt 0.7.3 (current stable) 
Target VersionOpenMPT 1.31.05.00 / libopenmpt 0.7.4 (upcoming stable)Fixed in VersionOpenMPT 1.31.05.00 / libopenmpt 0.7.4 (upcoming stable) 
Summary0001740: set_position_seconds not seeking correctly with allsongs mode
Description

set_position_seconds(..) doesn't seem to be calculating the expected base_seconds when handling a file with sub-songs as a single file (i.e. m_current_subsong == all_subsongs).
From a quick look it seems to be due to using "subsong->duration" instead of "subsongs[i].duration" for the base_seconds accumulate.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2024-01-10 17:59

administrator   ~0005818

Whoops, very true. Thanks for the analysis. Fixed in r20068.

manx

manx

2024-01-11 11:54

administrator   ~0005820

Issue History

Date Modified Username Field Change
2024-01-09 12:46 dro New Issue
2024-01-10 17:56 Saga Musix Assigned To => Saga Musix
2024-01-10 17:56 Saga Musix Status new => assigned
2024-01-10 17:59 Saga Musix Note Added: 0005818
2024-01-10 17:59 Saga Musix Status assigned => resolved
2024-01-10 17:59 Saga Musix Resolution open => fixed
2024-01-10 17:59 Saga Musix Fixed in Version => OpenMPT 1.31.05.00 / libopenmpt 0.7.4 (upcoming stable)
2024-01-10 17:59 Saga Musix Target Version => OpenMPT 1.31.05.00 / libopenmpt 0.7.4 (upcoming stable)
2024-01-11 11:54 manx Note Added: 0005820