View Issue Details

IDProjectCategoryView StatusLast Update
0001718OpenMPTlibopenmptpublic2023-10-04 14:10
Reporterlaamaa Assigned ToSaga Musix  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformany 
Product VersionOpenMPT 1.31.03.00 / libopenmpt 0.7.2 (upgrade first) 
Target VersionOpenMPT 1.31.04.00 / libopenmpt 0.7.3 (current stable)Fixed in VersionOpenMPT 1.31.04.00 / libopenmpt 0.7.3 (current stable) 
Summary0001718: set_pitch_factor does not affect FM instruments
Description

When playing .s3m files that use OPL2 FM instruments and samples, set_pitch_factor seems to change the pitch of sampled instruments only and FM instruments stay in the original pitch.

Example module to test with: https://api.modarchive.org/downloads.php?moduleid=201124#laamaa_-_gunshot.s3m

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2023-07-17 17:36

administrator   ~0005752

Fixed in r19472.

Saga Musix

Saga Musix

2023-07-17 17:41

administrator   ~0005753

This broke in r14608 through the introduction of the new finetune commands, so probably broken since libopenmpt 0.6.0.

Issue History

Date Modified Username Field Change
2023-07-11 06:50 laamaa New Issue
2023-07-11 07:21 Saga Musix Assigned To => Saga Musix
2023-07-11 07:21 Saga Musix Status new => assigned
2023-07-17 17:36 Saga Musix Note Added: 0005752
2023-07-17 17:37 Saga Musix Status assigned => resolved
2023-07-17 17:37 Saga Musix Resolution open => fixed
2023-07-17 17:37 Saga Musix Fixed in Version => OpenMPT 1.31.04.00 / libopenmpt 0.7.3 (current stable)
2023-07-17 17:37 Saga Musix Target Version => OpenMPT 1.31.04.00 / libopenmpt 0.7.3 (current stable)
2023-07-17 17:41 Saga Musix Note Added: 0005753