View Issue Details

IDProjectCategoryView StatusLast Update
0001581OpenMPTGeneralpublic2022-04-24 15:23
ReporterIcy_Guidance Assigned ToSaga Musix  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version7
Product VersionOpenMPT 1.30.03.00 / libopenmpt 0.6.2 (upgrade first) 
Target VersionOpenMPT 1.30.04.00 / libopenmpt 0.6.3 (current stable)Fixed in VersionOpenMPT 1.30.04.00 / libopenmpt 0.6.3 (current stable) 
Summary0001581: Selection off-centered in sample editor.
Description

Whenever I go and select a part of a sample in the sample editor, it's off-centered a little. This also applies to the sample drawing tool, making it harder to draw samples.

TagsNo tags attached.
Has the bug occurred in previous versions?No
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2022-03-18 14:02

administrator   ~0005138

Please provide clear reproduction steps for your issues, maybe with screenshots if that helps visualizing the problem you are encountering.

Saga Musix

Saga Musix

2022-03-18 17:51

administrator   ~0005139

I think I see an issue now that was introduced by relaxing the grab point calculation a bit (see changelog item "Improved behaviour when dragging a timeline item in the sample editor and the initial grab point wasn't exactly the horizontal position of the item." for OpenMPT 1.30.03.00). I think it works as intended when the sample is zoomed out but when zooming in, the new behaviour is not very practical. Can you confirm that you only see this issue when zooming into the sample? If not, I still need better reproduction steps because to me, the behaviour feels "natural" when zooming out.

Saga Musix

Saga Musix

2022-03-18 18:14

administrator   ~0005140

Drawing and dragging stuff around should now behave more predictably again when zooming into the sample as of r17143. You can grab a test build from https://builds.openmpt.org/builds/ (available in a few hours) or setting OpenMPT's update channel to "Next".

Saga Musix

Saga Musix

2022-04-24 15:23

administrator   ~0005170

No feedback -> assuming fixed.

Issue History

Date Modified Username Field Change
2022-03-18 13:57 Icy_Guidance New Issue
2022-03-18 14:02 Saga Musix Priority immediate => normal
2022-03-18 14:02 Saga Musix Severity major => minor
2022-03-18 14:02 Saga Musix Note Added: 0005138
2022-03-18 17:51 Saga Musix Note Added: 0005139
2022-03-18 18:14 Saga Musix Assigned To => Saga Musix
2022-03-18 18:14 Saga Musix Status new => assigned
2022-03-18 18:14 Saga Musix Status assigned => feedback
2022-03-18 18:14 Saga Musix Note Added: 0005140
2022-03-18 18:14 Saga Musix Target Version => OpenMPT 1.30.04.00 / libopenmpt 0.6.3 (current stable)
2022-04-24 15:23 Saga Musix Status feedback => resolved
2022-04-24 15:23 Saga Musix Resolution open => fixed
2022-04-24 15:23 Saga Musix Fixed in Version => OpenMPT 1.30.04.00 / libopenmpt 0.6.3 (current stable)
2022-04-24 15:23 Saga Musix Note Added: 0005170