View Issue Details

IDProjectCategoryView StatusLast Update
0001577OpenMPTUser Interfacepublic2022-03-06 12:41
ReporterWodd Assigned ToSaga Musix  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version10
Product VersionOpenMPT 1.31.00.* (current testing) 
Summary0001577: Pasting from pattern clipboard stops at tempo commands
Description

It seems that some information does not get copied in some files.

Steps To Reproduce
  1. Open insaniq2.mo3 (Extract from attached 7-Zip archive.)
  2. Navigate to pattern 14 (order 26).
  3. Activate Select All function to select the contents of the pattern.
  4. Copy the selection.
  5. Paste in another pattern (I recommend using the Insert Pattern command and using a blank pattern for this.)
Additional Information

If everything behaved as expected, you should observe that the C#538 on row 0 in channel 12 and the v07 in channel 11 are absent upon pasting the copied information. I do not know if any other modules do this.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

Wodd

Wodd

2022-03-06 10:57

reporter  

Insaniq2.7z (146,336 bytes)
Saga Musix

Saga Musix

2022-03-06 11:07

administrator   ~0005122

The commands are copy&pasted just fine here. I see no particular reason why they shouldn't be copied, either. You'll need to provide more information on your environmen and what exactly you're doing.

Saga Musix

Saga Musix

2022-03-06 11:23

administrator   ~0005124

Last edited: 2022-03-06 11:24

Also, please verify that the "missing" note information is present when you paste the clipboard content into a text editor like Notepad. If you have some helper applicaton running that mangles the text clipboard, it could be one reason why those notes go missing, for example.

Wodd

Wodd

2022-03-06 12:12

reporter   ~0005126

I have found that the information is present upon being pasted into a text editor. However, it is not copied back to OpenMPT. I did some more testing and found that, if I use the Select Channel command to copy only the information in channel 12, it is pasted with no problems. However, when I selected row 0 by clicking the 0 on the left side and copied it, pasting it into a blank pattern, only the information for channels 1-3 appears. Pasting the information into a text editor shows everything that was copied. Although I do not know why it would be useful or should behave any differently, I have attached a different file for you to try. The information of interest is in pattern 28.
Also, if it proves useful:
After opening Insaniquarium Suite.it:

  1. Select and remove patterns 0-26.
  2. Select and remove patterns 39-50.
  3. Select and remove patterns 52-68.
    At this point, you should be left with a total of 13 patterns (specifically, patterns 27-38 and pattern 51).
  4. Open the Cleanup dialog.
  5. Check the following items:
    In the Patterns category:
    a. Remove unused
    b. Rearrange
    In the Samples category:
    a. Remove unused
    b. Rearrange
    In the Instruments category:
    Remove unused
    In the Plugins category:
    Remove unused
    In the Miscellaneous category:
    Remove unused channels
    Click OK and click Yes on the dialogs that appear.
    You should now have 13 patterns labeled 0-12. Copy the information in pattern 1 and paste it into a new pattern. You should try both selecting all information and selecting only row 0 to see if everything pastes as intended both times. You might want to use 2 blank patterns (one containing the entire contents of pattern 1 and the other containing the content of row 0 only). I used the Undo command after each paste operation. In theory, either method should produce the same results.
    Worst-case scenario: I need to copy all 13 patterns individually on a per-channel basis. That will take a while. But, if that is what needs to be done, that is what needs to be done.
Insaniquarium Suite.7z (3,254,810 bytes)
Saga Musix

Saga Musix

2022-03-06 12:39

administrator   ~0005127

Ah, I was testing with the latest stable version, this only occurs on tempo and speed commands in current test builds.

Saga Musix

Saga Musix

2022-03-06 12:41

administrator   ~0005128

r17068 fixes this.

Issue History

Date Modified Username Field Change
2022-03-06 10:57 Wodd New Issue
2022-03-06 10:57 Wodd File Added: Insaniq2.7z
2022-03-06 11:07 Saga Musix Note Added: 0005122
2022-03-06 11:23 Saga Musix Note Added: 0005124
2022-03-06 11:24 Saga Musix Note Edited: 0005124
2022-03-06 12:12 Wodd Note Added: 0005126
2022-03-06 12:12 Wodd File Added: Insaniquarium Suite.7z
2022-03-06 12:37 Saga Musix Assigned To => Saga Musix
2022-03-06 12:37 Saga Musix Status new => assigned
2022-03-06 12:37 Saga Musix Summary Some Information Not Being Copied (?) => Pasting from pattern clipboard stops at tempo commands
2022-03-06 12:39 Saga Musix Note Added: 0005127
2022-03-06 12:41 Saga Musix Status assigned => resolved
2022-03-06 12:41 Saga Musix Resolution open => fixed
2022-03-06 12:41 Saga Musix Note Added: 0005128