View Issue Details

IDProjectCategoryView StatusLast Update
0001558OpenMPTBuild Systempublic2023-01-24 10:23
ReporterSaga Musix Assigned Tomanx  
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Product VersionOpenMPT 1.31.00.* (current testing) 
Target VersionOpenMPT 1.31 / libopenmpt 0.7 (goals)Fixed in VersionOpenMPT 1.31 / libopenmpt 0.7 (goals) 
Summary0001558: Split build/auto into user-invocable and helper scripts
Description

build/auto contains a mixture of scripts that are intended to be invoked by the user or build infrastructure, and other scripts which are just helper scripts to the aforementioned scripts. It's easy to get lost between dozens of script files, so it could be a good idea to split the helper scripts into a sub directory, making it obvious which scripts are intended to be called by the user and which are not.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

manx

manx

2023-01-23 19:33

administrator   ~0005494

I think the only scripts that really remain to be meant user invokable scripts are the release building scripts:

  • build/auto/build_openmpt_release_manual.cmd
  • build/auto/build_openmpt_release_manual_retro.cmd

So, the least intrusive way to resolve this issue would IMHO be to just move these 2 scripts 1 directory up into build/ where all other developer-invokable scripts reside currently anyway (and give them a shorter name).

Saga Musix

Saga Musix

2023-01-23 19:59

administrator   ~0005495

Sounds sensible.

manx

manx

2023-01-23 20:15

administrator   ~0005496

r18605

Issue History

Date Modified Username Field Change
2022-01-30 11:53 Saga Musix New Issue
2022-01-30 17:21 manx Assigned To => manx
2022-01-30 17:21 manx Status new => assigned
2022-01-30 17:21 manx Product Version => OpenMPT 1.31.00.* (current testing)
2022-01-30 17:21 manx Target Version => OpenMPT 1.31 / libopenmpt 0.7 (goals)
2023-01-23 19:33 manx Note Added: 0005494
2023-01-23 19:33 manx Status assigned => feedback
2023-01-23 19:59 Saga Musix Note Added: 0005495
2023-01-23 19:59 Saga Musix Status feedback => assigned
2023-01-23 20:15 manx Status assigned => resolved
2023-01-23 20:15 manx Resolution open => fixed
2023-01-23 20:15 manx Fixed in Version => OpenMPT 1.31 / libopenmpt 0.7 (goals)
2023-01-23 20:15 manx Note Added: 0005496