View Issue Details

IDProjectCategoryView StatusLast Update
0001537OpenMPTGeneralpublic2021-12-25 14:31
ReporterThe_Muzykant Assigned Tomanx  
PrioritynormalSeverityminorReproducibilityunable to reproduce
Status closedResolutionno change required 
Platformx64OSWindowsOS Version10
Product VersionOpenMPT 1.30.01.00 / libopenmpt 0.6.0 (current stable) 
Target VersionOpenMPT 1.30.02.00 / libopenmpt 0.6.1 (upcoming stable) 
Summary0001537: Unable to install OpenMPT due to failing uninstall of previous version
Description

When trying to install the new version of OpenMPT 1.30.01.00, a message later pops up saying "There was a problem removing the previous OpenMPT installation." When I click OK, another message pops up saying, "Runtime error (at 20:274): Uninstallation of previous OpenMPT installation failed. Please uninstall manually."

I find this peculiar, since upon inspecting, I found that the previous version was already uninstalled both 32bit and 64bit

Additional Information

UPDATE: I just found a workaround, which is that if I decide to install the portable version, I can open up OpenMPT now. Obviously the inconvenience is that now I have to re-import my colour scheme. But besides that, everything works well. I don't need to use a .exe to install the application for the portable version. Maybe the .exe has an issue? No idea...

UPDATE 2.1: I found that I am unable to associate OpenMPT with .IT files, .XM files, .MOD files, etc. I suppose this would be the disadvantage of the portable version? But I have no problem opening the files, just so you know. Just a little annoying that the files aren't associated and cannot be associated.

25 December 2021:
UPDATE 2.2: I found that OpenMPT 1.29.09.00 (32-Bit) still exists in the Apps, but then when I click the uninstall button, it doesn't work. It says that it failed to locate the unins000.exe (probably because OpenMPT 1.30.01.00 deleted it already before this when I used the installer). I have not tried the registry thingy that the fellow administrator has suggested. I'll work on it when I can properly concentrate on that stuff. Don't wanna mess up by accident!

UPDATE 2.3: No matter which option I choose, be it "install for me only" or "for all", the installer does not work at all.

TagsNo tags attached.
Has the bug occurred in previous versions?Nope.
Tested code revision (in case you know it)

Activities

The_Muzykant

The_Muzykant

2021-12-24 03:26

reporter  

OpenMPT error.png (18,513 bytes)   
OpenMPT error.png (18,513 bytes)   
manx

manx

2021-12-24 06:56

administrator   ~0004965

Are any of the old OpenMPT versions still listed in the Windows Settings panel "Apps"?

Did you choose "Install for all users" or "Install for me only" for OpenMPT 1.30?

Can you check if there are still any remaining entries in the registry at the following locations?

  • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall\{67903736-E9BB-4664-B148-F62BCAB4FA42}_is1\
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{9814C59D-8CBE-4C38-8A5F-7BF9B4FFDA6D}_is1\

In order to check that, you need to open regedit.exe / "Registry Editor" and navigate to the respective locations, and please be careful to not change anything accidentally.

manx

manx

2021-12-24 08:25

administrator   ~0004966

Last edited: 2021-12-24 08:25

I just found a workaround, which is that if I decide to install the portable version, I can open up OpenMPT now. Obviously the inconvenience is that now I have to re-import my colour scheme.

If you remove the file OpenMPT.portable from the portable installation, it should use all your old settings again.

Even with your work-around, we would appreciate if you could provide further details, so that we can hopefully fix the root cause of the installer failure.

manx

manx

2021-12-25 08:30

administrator   ~0004967

I found that I am unable to associate OpenMPT with .IT files, .XM files, .MOD files, etc. I suppose this would be the disadvantage of the portable version? But I have no problem opening the files, just so you know. Just a little annoying that the files aren't associated and cannot be associated.

You can still associate file types even for programs that are not installed and registered with the system, but you need to do that manually:

  1. select the file in explorer, and choose "Open with" from the context menu
  2. select "More apps"
  3. navigate to the bottom of the list and select "Look for another app on this PC"
  4. find "OpenMPT.exe"

However, please do not do this yet, as we will hopefully find a way to properly install OpenMPT 1.30 for you.

I found that OpenMPT 1.29.09.00 (32-Bit) still exists in the Apps, but then when I click the uninstall button, it doesn't work. It says that it failed to locate the unins000.exe

Did you have 32bit and 64bit OpenMPT installed in separate paths, or did you install them on top of each other to the same path? The latter was never supported (and is for no Windows program at all), and would have resulted in only 1 OpenMPT (the one installed later) being actually available. Even in that latter case, however, my tests show that the OpenMPT 1.30 installer should be able to handle that and uninstall properly, however it might have caused some confusion for the earlier installers, especially when previously updating the 1.29 install with later 1.29 versions. The registry information might still be useful.

Now, trying to find a simple solution:
If only OpenMPT 1.29 32bit still shows up in the installed Apps, you can try doing the following:

  1. Install OpenMPT 1.29.15.00 (32bit) (<https://download.openmpt.org/archive/openmpt/1.29/OpenMPT-1.29.15.00-Setup.exe>)
  2. Now try to install OpenMPT 1.30. Choosing "install for all users".
  3. If you have copied your portable installation to the path where you previously and/or now had/have OpenMPT installed, delete the file OpenMPT.portable.

Also: Could you please just add further comments as a separate note at the bottom of this issue instead of editing the additional information. It makes following longer discussions easier in the long term.

The_Muzykant

The_Muzykant

2021-12-25 14:25

reporter   ~0004969

Message acknowledged on the whole bit about adding notes here instead of editing. Sorry, I'm a bit new here!

Also, I found the solution. As it turns out, I had to go to Control Panel, followed by Programs and Features, click uninstall on OpenMPT 32-bit (only the 32-bit one was there btw), then it says that the app is apparently already deleted and then a pop-up requests for me to remove the app from the list. I say yes and then the OpenMPT 32-bit is gone. I click on the 1.30.01.00 setup.exe and it works! Installation was a success!

Before this, I was going into Apps in Settings, which did not remove the app from the list. Only when I went into Control Panel, it worked.

I have not tried if your solution works. But it seems I might have found a part of the root problem.

manx

manx

2021-12-25 14:29

administrator   ~0004970

Your solution is equally good as the solution that I suggested, so everything should be fine now.

You should still check that there is no OpenMPT.portable file still laying around anywhere in the installation, as this would cause OpenMPT to not use your old settings.

Issue History

Date Modified Username Field Change
2021-12-24 03:26 The_Muzykant New Issue
2021-12-24 03:26 The_Muzykant File Added: OpenMPT error.png
2021-12-24 06:04 The_Muzykant Priority high => immediate
2021-12-24 06:04 The_Muzykant Description Updated
2021-12-24 06:11 The_Muzykant Priority immediate => high
2021-12-24 06:11 The_Muzykant Summary Unable to install OpenMPT => Unable to install OpenMPT [UPDATE]
2021-12-24 06:11 The_Muzykant Description Updated
2021-12-24 06:11 The_Muzykant Additional Information Updated
2021-12-24 06:56 manx Status new => feedback
2021-12-24 06:56 manx Note Added: 0004965
2021-12-24 07:18 manx Target Version => OpenMPT 1.30.02.00 / libopenmpt 0.6.1 (upcoming stable)
2021-12-24 08:25 manx Note Added: 0004966
2021-12-24 08:25 manx Note Edited: 0004966
2021-12-25 02:23 The_Muzykant Summary Unable to install OpenMPT [UPDATE] => Unable to install OpenMPT [UPDATE 2]
2021-12-25 02:23 The_Muzykant Additional Information Updated
2021-12-25 02:24 The_Muzykant Additional Information Updated
2021-12-25 08:30 manx Note Added: 0004967
2021-12-25 08:30 manx Summary Unable to install OpenMPT [UPDATE 2] => Unable to install OpenMPT due to failing uninstall of previous version
2021-12-25 14:25 The_Muzykant Note Added: 0004969
2021-12-25 14:25 The_Muzykant Status feedback => new
2021-12-25 14:27 The_Muzykant Priority high => normal
2021-12-25 14:27 The_Muzykant Additional Information Updated
2021-12-25 14:28 The_Muzykant Severity block => minor
2021-12-25 14:28 The_Muzykant Additional Information Updated
2021-12-25 14:29 manx Note Added: 0004970
2021-12-25 14:30 manx Reproducibility always => unable to reproduce
2021-12-25 14:31 manx Assigned To => manx
2021-12-25 14:31 manx Status new => closed
2021-12-25 14:31 manx Resolution open => no change required