View Issue Details

IDProjectCategoryView StatusLast Update
0001449OpenMPTGeneralpublic2021-04-27 17:47
Reportertennisers Assigned ToSaga Musix  
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version10
Product VersionOpenMPT 1.29.09.00 / libopenmpt 0.5.8 (current stable) 
Target VersionOpenMPT 1.29.10.00 / libopenmpt 0.5.9 (upcoming stable)Fixed in VersionOpenMPT 1.29.10.00 / libopenmpt 0.5.9 (upcoming stable) 
Summary0001449: Saving .xi instruments with sample frequency < 8363 Hz does not save correct sample transposition values
Description

Saving multisample .xi instruments sometimes does not save modified sample transposition values.
(This does not affect saving as .iti, I did not try other instrument file types yet.)

Steps To Reproduce

Create an instrument with 5 samples,
Transpose all of the samples in their respective sample tabs,
save as xi instrument
notice that one of the samples is not saved with the transposition value you assigned
Every time i tried this, it was the highest sample that was transposed 1 semitone higher.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2021-04-27 11:48

administrator   ~0004728

I cannot reproduce that here, so more precise reproduction steps are necessary. To be sure, do you mean that you change the transpose values in the sample tab, or are you transposing the sample map of the instrument? The latter isn't possible in XM / XI, so e.g. C-5 will always map to C-5.

tennisers

tennisers

2021-04-27 12:01

reporter   ~0004729

Yes, in the sample tab. Here is the instrument i was seeing this problem with currently, the "hisser 5" sample is always transposed to F#4 when I am saving as F4.

hisser cut.zip (2,833 bytes)
tennisers

tennisers

2021-04-27 12:03

reporter   ~0004730

I marked reproducibility as "sometimes" because there are some instruments where i always have this problem every single time, but with other instruments i never run into it.

Saga Musix

Saga Musix

2021-04-27 12:56

administrator   ~0004731

Which module format are you working in while working with the instrument?

Saga Musix

Saga Musix

2021-04-27 17:03

administrator   ~0004732

Last edited: 2021-04-27 17:47

I think I found the issue now; this is a variant of a bug that was fixed a while ago when converting MPTM/IT/S3M to XM, but it wasn't fixed when saving an XI file from within an IT/MPTM module. This only affects samples with a middle-C frequency below 8363 Hz. I'll provide a fix shortly.

Saga Musix

Saga Musix

2021-04-27 17:38

administrator   ~0004733

Should be fixed in r14687 (+ backport for OpenMPT 1.29 in r14688), available in an hour or two at https://builds.openmpt.org/builds/

Issue History

Date Modified Username Field Change
2021-04-27 11:41 tennisers New Issue
2021-04-27 11:42 tennisers Description Updated
2021-04-27 11:48 Saga Musix Note Added: 0004728
2021-04-27 11:49 tennisers Product Version OpenMPT 1.29.06.00 / libopenmpt 0.5.4 (upgrade first) => OpenMPT 1.29.09.00 / libopenmpt 0.5.8 (current stable)
2021-04-27 11:49 tennisers Steps to Reproduce Updated
2021-04-27 11:52 tennisers Steps to Reproduce Updated
2021-04-27 12:01 tennisers Note Added: 0004729
2021-04-27 12:01 tennisers File Added: hisser cut.zip
2021-04-27 12:03 tennisers Note Added: 0004730
2021-04-27 12:56 Saga Musix Note Added: 0004731
2021-04-27 16:53 Saga Musix Assigned To => Saga Musix
2021-04-27 16:53 Saga Musix Status new => assigned
2021-04-27 17:03 Saga Musix Note Added: 0004732
2021-04-27 17:38 Saga Musix Note Added: 0004733
2021-04-27 17:39 Saga Musix Status assigned => resolved
2021-04-27 17:39 Saga Musix Resolution open => fixed
2021-04-27 17:39 Saga Musix Fixed in Version => OpenMPT 1.29.10.00 / libopenmpt 0.5.9 (upcoming stable)
2021-04-27 17:39 Saga Musix Target Version => OpenMPT 1.29.10.00 / libopenmpt 0.5.9 (upcoming stable)
2021-04-27 17:46 Saga Musix Summary Saving multisample .xi instruments sometimes does not save modified sample transposition values => Saving .xi instruments with sample frequency < 8363 Hz does not save correct sample transposition values
2021-04-27 17:47 Saga Musix Note Edited: 0004732