View Issue Details

IDProjectCategoryView StatusLast Update
0001429OpenMPTGeneralpublic2021-08-22 17:13
ReporterSaga Musix Assigned To 
PrioritylowSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Target VersionOpenMPT 1.30 / libopenmpt 0.6 (goals)Fixed in VersionOpenMPT 1.30 / libopenmpt 0.6 (goals) 
Summary0001429: Force shared instance via INI setting
Description

Right now OpenMPT can only be put into shared instance mode by adding the /sharedcommand line parameter; this can be difficult if the file association was made by hand (e.g. for a file extension not officially used by OpenMPT). It might be a good idea to have a (hidden, for now) setting in the INI file which would also enforce this mode no matter how file extensions were set up. Obviously this is not quite as ideal as the command line parameter because it cannot be caught as early (and will thus be a bit slower), but may still be the easier solution for some people.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Relationships

related to 0001123 resolvedmanx Provide unified multi-arch installer 
related to 0001430 new decide how /shared should behave with non-matching architectures of OpenMPT.exe 

Activities

Saga Musix

Saga Musix

2021-05-14 22:56

administrator   ~0004768

r14972 adds Misc.UseSingleInstance hidden setting.

Issue History

Date Modified Username Field Change
2021-03-02 19:49 Saga Musix New Issue
2021-03-02 19:52 manx Relationship added related to 0001123
2021-03-02 19:58 manx Target Version => OpenMPT 1.30 / libopenmpt 0.6 (goals)
2021-03-02 20:00 manx Relationship added related to 0001130
2021-03-02 20:01 manx Relationship added related to 0001430
2021-03-02 20:01 manx Relationship deleted related to 0001130
2021-05-14 22:56 Saga Musix Note Added: 0004768
2021-05-14 22:56 Saga Musix Status new => resolved
2021-05-14 22:56 Saga Musix Resolution open => fixed
2021-05-14 22:56 Saga Musix Fixed in Version => OpenMPT 1.30 / libopenmpt 0.6 (goals)