View Issue Details

IDProjectCategoryView StatusLast Update
0001399OpenMPTUser Interfacepublic2020-12-25 18:30
ReporterAyCe Assigned ToSaga Musix  
PrioritynormalSeveritycrashReproducibilitysometimes
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version7
Product VersionOpenMPT 1.29.06.00 / libopenmpt 0.5.4 (current stable) 
Target VersionOpenMPT 1.29.07.00 / libopenmpt 0.5.5 (upcoming stable)Fixed in VersionOpenMPT 1.29.07.00 / libopenmpt 0.5.5 (upcoming stable) 
Summary0001399: Sometimes crash when exporting MID
Description

Sometimes OpenMPT crashes when exporting IT files as MID. When I open the file again after the crash and export again it works. It seems it only happens when you work with the file for a while. This has not happened on previous versions.

Steps To Reproduce

Edit a module file.
Export as MID.

Sometimes you get a crash right when the progress dialog shows.

Additional Information

I've set the MIDI Channel for some non-drums instruments because otherwise the export functionally does not quite work.
No effects, nothing fancy at all. Some +++ patterns between normal patterns.

TagsNo tags attached.
Has the bug occurred in previous versions?No
Tested code revision (in case you know it)

Activities

AyCe

AyCe

2020-12-18 17:48

reporter  

crashes.zip (55,044 bytes)
Saga Musix

Saga Musix

2020-12-18 19:19

administrator   ~0004549

I can see where the crash happens but for the sake of making reproducing the issue easier, can you maybe provide the file you were trying to export?

AyCe

AyCe

2020-12-18 20:34

reporter   ~0004550

As I wrote, the crash is unreliable. I would like to supply you with a version of the file that fails the export, but for exporting the old autosaved file versions I didn't have an issue. It seems to be related to working on a file for some time, just opening and exporting, even changing some things and then exporting seems to work fine with all files I have so far.

Will add a file if I find one.

Saga Musix

Saga Musix

2020-12-18 20:45

administrator   ~0004551

If you have the possibility to upload larger files somewhere, you could also run OpenMPT with the /fullMemDump command line option. The resulting memory dump file will be much bigger, but it will compress quite well with 7z or RAR (not so much with zip). This would be very helpful.

Saga Musix

Saga Musix

2020-12-18 22:57

administrator   ~0004552

I found a potential reason for the issue, which should be fixed in r13962 and later (soon available from https://builds.openmpt.org/builds/auto/openmpt/bin.win64/1.29/ ) - however if you can provoke the crash with the current stable version using the /fullMemDump would still be appreciated as it would help understanding how OpenMPT ended up in this situation that led to the crash.

AyCe

AyCe

2020-12-19 18:07

reporter   ~0004554

Sure! I don't use OpenMPT very often, but I will run it with that command line option from now on.

AyCe

AyCe

2020-12-25 03:37

reporter   ~0004563

I can reliably reproduce the/"a" crash with this file:

  1. Open it
  2. Go to Instruments Tab
  3. Replace the only and only instrument with Piano 1 from SGM-V2.01.sf2
  4. Export as MID, just click OK
crashing module.zip (184,508 bytes)
Saga Musix

Saga Musix

2020-12-25 15:55

administrator   ~0004565

Thanks for the steps. I can reproduce the problem now. It seems like you forgot to add the link to the memory dump but as I now have a way of reproducing the issue, it is no longer required.

Saga Musix

Saga Musix

2020-12-25 18:30

administrator   ~0004567

Okay, I can now confirm that the root cause of this issue is in SF2 instrument extraction and thus won't happen after saving and re-loading the module. The root cause was fixed in r13988 and the problem won't happen anymore in the next OpenMPT release.

Issue History

Date Modified Username Field Change
2020-12-18 17:48 AyCe New Issue
2020-12-18 17:48 AyCe File Added: crashes.zip
2020-12-18 19:19 Saga Musix Note Added: 0004549
2020-12-18 19:19 Saga Musix Assigned To => Saga Musix
2020-12-18 19:19 Saga Musix Status new => assigned
2020-12-18 20:34 AyCe Note Added: 0004550
2020-12-18 20:45 Saga Musix Note Added: 0004551
2020-12-18 22:57 Saga Musix Note Added: 0004552
2020-12-18 22:57 Saga Musix Status assigned => feedback
2020-12-19 18:07 AyCe Note Added: 0004554
2020-12-19 18:07 AyCe Status feedback => assigned
2020-12-25 03:37 AyCe Note Added: 0004563
2020-12-25 03:37 AyCe File Added: crashing module.zip
2020-12-25 15:55 Saga Musix Note Added: 0004565
2020-12-25 18:30 Saga Musix Note Added: 0004567
2020-12-25 18:30 Saga Musix Status assigned => resolved
2020-12-25 18:30 Saga Musix Resolution open => fixed
2020-12-25 18:30 Saga Musix Fixed in Version => OpenMPT 1.29.07.00 / libopenmpt 0.5.5 (upcoming stable)
2020-12-25 18:30 Saga Musix Target Version => OpenMPT 1.29.07.00 / libopenmpt 0.5.5 (upcoming stable)