View Issue Details

IDProjectCategoryView StatusLast Update
0001382OpenMPTGeneralpublic2021-02-23 22:32
Reporterfwl Assigned ToSaga Musix  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version10
Product VersionOpenMPT 1.29.04.00 / libopenmpt 0.5.2 (upgrade first) 
Target VersionOpenMPT 1.29.08.00 / libopenmpt 0.5.6 (upcoming stable)Fixed in VersionOpenMPT 1.29.08.00 / libopenmpt 0.5.6 (upcoming stable) 
Summary0001382: OPL Instrument view breaks shortcuts for general, pattern, instrument and comment view
Description

When you press Alt-S to go to Sample View and then press Ctrl-up or down to scroll through the samples whenever you reach an OPL instrument the shortcuts ALt-G, ALt-P Alt-N and Alt-C don't work anymore. It seems after a closer look it has to do with the focus on the checkbox 'additive synthesis'. When I press Tab to loose the focus on this checkbox the shortcuts work again. But still when I go back to the OPL-view this checkbox is in focus again.

Steps To Reproduce

When you press Alt-S to go to Sample View and then press Ctrl-up or down to scroll through the samples whenever you reach an OPL instrument the shortcuts ALt-G, ALt-P Alt-N and Alt-C don't work anymore. It seems after a closer look it has to do with the focus on the checkbox 'additive synthesis'. When I press Tab to loose the focus on this checkbox the shortcuts work again. But still when I go back to the OPL-view this checkbox is in focus again.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2020-10-18 21:21

administrator   ~0004479

Even with these steps I cannot reproduce the issue - maybe because here the checkbox is never focussed automatically? I would actually want it to be focussed for accessibility reasons, but it definitely isn't focussed here after switching to an OPL instrument. I have to actively click on it to give it focus, and even then the shortcuts keep working for me. Strange!

fwl

fwl

2020-10-18 21:25

reporter   ~0004480

In addition to the report, OPENMPT loses focus as a program when selecting a OPL-instrument with shortcut Alt-S. Pressing Tab or arrow keys brings the focus back.

Saga Musix

Saga Musix

2020-10-18 21:26

administrator   ~0004481

Okay, THAT definitely sounds like some third-party software must be interfering with OpenMPT.

fwl

fwl

2020-10-18 21:41

reporter   ~0004482

Ok I'll see if I can figure out which software. But it is strange that it only affects Openmpt when an OPL instrument is selected... it works fine if it's a sample that gets selected with the shortcut Alt-S

Saga Musix

Saga Musix

2021-02-21 17:11

administrator   ~0004648

If this bug still happens to you, can you please check if this test build works better? https://builds.openmpt.org/builds/auto/openmpt/bin.win64/1.29/openmpt-win64-1.29.07.01-r14199.7z

fwl

fwl

2021-02-23 10:15

reporter   ~0004650

Hello Saga,

I've checked if the bug was still there in version 1.29.07.00 and it isn't. So it is allready solved in the latest official version if it was a problem with Openmpt to begin with and not caused by variables on my side.

In the 1.29.07.01 the issue is also solved, except here you can't enter the parameters of the OPL-instrument for editing by pressing Tab. This is still possible in the 1.29.07.00 version. So in that respect the .00 version works better.

Saga Musix

Saga Musix

2021-02-23 10:22

administrator   ~0004651

I don't think there was any change since you reported the original issue that would fix it, but if you have the time maybe you could double-check if it still happens with OpenMPT 1.29.04.00 (link leads to portable version for easy testing).

It's strange that the Tab key doesn't work for you with the new version, as there shouldn't be a difference in that regard; it also works just fine here so I think that the original problem might still not be solved just is exposed in a different way now.

By the way, another user had a similar problem , which is why I came back to this issue. They noticed that when the OPL editor is focussed, it would seem like the main OpenMPT window loses focus and its title bar becomes greyed out as a result. Can you remember if you experienced something similar, or do you maybe even still see it with the latest version? If so, it would perfectly explain why the shortcuts stopped working for you.

fwl

fwl

2021-02-23 10:42

reporter   ~0004652

I did some further testing and the issue with the TAB not working only occurs when the first sampleslot created is an OPL-instrument. When you first add samples then TAB does work and the Additive Synthesis checkbox has first focus.

And yes if you pressed Alt-S and the shortcut lead you to an OPL-instrument, Openmpt would lose focus as a program.

I will test some things with the 1.29.04.00 as well

fwl

fwl

2021-02-23 11:16

reporter   ~0004653

Hi Saga,

I'm sorry, I was a little too hasty with testing. I had to recall/refresh what the issue details were. The test results are:

1.29.04.00 : when selecting an OPL instrument with Alt-S the shortcuts Alt-P,-G, -C, -N don't work anymore. So you can't return to pattern view for example. Alt-I does work. This goes for every sample slot. So when you scroll down to a sample slot below or above the OPL instrument the shortcuts still don't work. It's because Openmpt loses focus as a program and the main window gets greyed out like you said.
1.29.07.00: same as above. So my first results were not correct (sorry)
1.29.07.01: issue is solved, but no you can't get the focus on the OPL-editor with the keyboard with for example TAB. You have to use the mouse.

While testing I also ran into another shortcut issue: when you are in the comment tab and switch to tree view with Alt-I you can't return to the comment tab with Alt-C

Saga Musix

Saga Musix

2021-02-23 17:25

administrator   ~0004654

Okay, that's great news. I'm sure we can fix the remaining issue with the tab key as well. I'll try some things and give you a new build to test soon.

Saga Musix

Saga Musix

2021-02-23 17:53

administrator   ~0004655

Does the Tab key work for you after clicking on one of the controls, or does just never work at all?

fwl

fwl

2021-02-23 19:32

reporter   ~0004656

It works when you click one of the parameter controls and then the dashed border appears to indicate that its is in focus. After that you can scroll through the controls using TAb and Shift Tab. But when you leave the sample editor and then go back to the sample editor you have to use the mouse again for the first control selection

Saga Musix

Saga Musix

2021-02-23 20:02

administrator   ~0004657

Okay, so we're on the same page then. This is how it worked for me before and after the fix, and it's how it worked on all other machines I could try so far. I'm not fully sure why it happens (and I tried fixing it before so I'm kinda out of ideas on that topic), so I would propose to close this issue (as the original problem is fixed), but I will continue to figure out why the keyboard focus doesn't work properly.

fwl

fwl

2021-02-23 20:47

reporter   ~0004658

Yes that's fine by me. The keyboard focus in the OPL instrument isn't that big of an issue. That you've got the other issue fixed is great and makes the switching between sample view and the other views with OPL-instruments in the sample-pool a lot smoother. So, Thanks!

Saga Musix

Saga Musix

2021-02-23 22:32

administrator   ~0004659

I just dug a bit more into this code and I think I have finally found the root cause for the keyboard focus problem. r14203 should be available for testing in about 1-2 hours from here:
https://builds.openmpt.org/builds/auto/openmpt/bin.win64/1.29/

Issue History

Date Modified Username Field Change
2020-10-18 21:13 fwl New Issue
2020-10-18 21:21 Saga Musix Note Added: 0004479
2020-10-18 21:25 fwl Note Added: 0004480
2020-10-18 21:26 Saga Musix Note Added: 0004481
2020-10-18 21:41 fwl Note Added: 0004482
2021-02-21 17:11 Saga Musix Note Added: 0004648
2021-02-23 10:15 fwl Note Added: 0004650
2021-02-23 10:22 Saga Musix Note Added: 0004651
2021-02-23 10:42 fwl Note Added: 0004652
2021-02-23 11:16 fwl Note Added: 0004653
2021-02-23 17:25 Saga Musix Note Added: 0004654
2021-02-23 17:25 Saga Musix Assigned To => Saga Musix
2021-02-23 17:25 Saga Musix Status new => assigned
2021-02-23 17:53 Saga Musix Note Added: 0004655
2021-02-23 19:32 fwl Note Added: 0004656
2021-02-23 20:02 Saga Musix Note Added: 0004657
2021-02-23 20:47 fwl Note Added: 0004658
2021-02-23 22:01 Saga Musix Status assigned => resolved
2021-02-23 22:01 Saga Musix Resolution open => fixed
2021-02-23 22:01 Saga Musix Fixed in Version => OpenMPT 1.29.08.00 / libopenmpt 0.5.6 (upcoming stable)
2021-02-23 22:01 Saga Musix Target Version => OpenMPT 1.29.08.00 / libopenmpt 0.5.6 (upcoming stable)
2021-02-23 22:32 Saga Musix Note Added: 0004659