View Issue Details

IDProjectCategoryView StatusLast Update
0001344OpenMPTPlayback Compatibilitypublic2021-06-02 22:53
ReporterWizArthur Assigned ToSaga Musix  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version7
Product VersionOpenMPT 1.29.01.00 / libopenmpt 0.5.0 (upgrade first) 
Target VersionOpenMPT 1.30 / libopenmpt 0.6 (goals)Fixed in VersionOpenMPT 1.30 / libopenmpt 0.6 (goals) 
Summary0001344: Tuning issue in Impulse Tracker file with Amiga pitch slides
Description

The tuning of the portamentos in the melodies (starting at 0:30) of the attached song often go sharp of the target note. This issue has stumped me since '99 because it has played back differently in almost every player outside of IT. Best guess is that it is related to the Amiga pitch slides setting (in F12 settings), possibly combined with the high octave used for leads. It almost seems to go proportionally sharper with higher notes.

I recently tested this issue in Schism 20190801, ModPlug Player 1.46.02, XMPlay 3.8.4, and foo_openmpt54 0.5.0. Most players sounded similarly out of tune with only XMPlay getting close to IT.

The attachment includes the original IT file as well as a short clip with accurate pitch rendered using IT 2.14's stereo WAV writer.

TagsNo tags attached.
Has the bug occurred in previous versions?Yes
Tested code revision (in case you know it)

Activities

WizArthur

WizArthur

2020-06-27 15:37

reporter  

watching.zip (479,154 bytes)
Saga Musix

Saga Musix

2020-06-27 16:08

administrator   ~0004390

Last edited: 2020-08-25 11:33

Amiga pitch slides in IT are indeed a bit weird and finnicky. It's been on my to-do list for a very long time to look into them and try to fix them...

Note to self: relevant sackit2 commit

Saga Musix

Saga Musix

2021-05-02 16:02

administrator   ~0004737

r14767 / OpenMPT 1.30.00.36 should fix the inaccurate slides when Linear Slides are disabled. It will be available for testing soon (in 1-2 hours) from https://builds.openmpt.org/builds/

Please give it a try, also with other formats because a lot of pitch slide logic was rearranged. I hope it didn't break anything!

Saga Musix

Saga Musix

2021-05-07 10:09

administrator   ~0004759

There was a bug in the new code that stopped notes in some cases if tone portamento overshot the target note too much; this is now fixed in r14850.

Issue History

Date Modified Username Field Change
2020-06-27 15:37 WizArthur New Issue
2020-06-27 15:37 WizArthur File Added: watching.zip
2020-06-27 16:08 Saga Musix Note Added: 0004390
2020-06-27 17:06 Saga Musix Assigned To => Saga Musix
2020-06-27 17:06 Saga Musix Status new => assigned
2020-08-25 11:33 Saga Musix Note Edited: 0004390
2021-05-02 14:58 Saga Musix Target Version => OpenMPT 1.30 / libopenmpt 0.6 (goals)
2021-05-02 14:58 Saga Musix Category Player input plugins (xmp-openmpt, in_openmpt) => Playback Compatibility
2021-05-02 16:02 Saga Musix Status assigned => feedback
2021-05-02 16:02 Saga Musix Note Added: 0004737
2021-05-07 10:09 Saga Musix Note Added: 0004759
2021-06-02 22:53 Saga Musix Status feedback => resolved
2021-06-02 22:53 Saga Musix Resolution open => fixed
2021-06-02 22:53 Saga Musix Fixed in Version => OpenMPT 1.30 / libopenmpt 0.6 (goals)