View Issue Details

IDProjectCategoryView StatusLast Update
0001250OpenMPTUser Interfacepublic2019-08-22 19:54
ReporterFred57 Assigned ToSaga Musix  
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx86OSWindows 
Product VersionOpenMPT 1.28.06.00 / libopenmpt 0.4.6 (upgrade first) 
Target VersionOpenMPT 1.28.07.00 / libopenmpt 0.4.7 (upgrade first)Fixed in VersionOpenMPT 1.28.07.00 / libopenmpt 0.4.7 (upgrade first) 
Summary0001250: record button enabled while playing a song and action on the grid
Description

Hi,

Play a song and be sure that the button record is enabled
Click on the grid (espacialy on the 2 last parameters for fine volume, portamento etc...) with detail = High to see those parameters.
The first time you press on the 'E' key you have got a message : editing recording is enabled, click here...
If you continue to press on 'E' key message disapears and button record is disabled, and you can change the parameters with keys A E etc...

You can double click and change values too whereas button record is enabled, this action is not normal.

If this was a VB app I would put : grid1.enabled = false to prevent this kind of problem when record button is disable.

Regards,
Fred

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2019-08-13 16:02

administrator   ~0004005

If this was a VB app I would put : grid1.enabled = false to prevent this kind of problem when record button is disable.

This completely ignores that the pop-up is a deliberate and wanted feature; If you prefer not to see this popup and accidentally enable editing, you can set the NoEditPopup secret setting.

The only thing up for discussion here isn't the popup itself but whether the "E" key should be an mnemonic key for accepting the popup as it currently is. It is probably a bit too dangerous because it it can also be used for note and effect entry.

Saga Musix

Saga Musix

2019-08-13 17:06

administrator   ~0004006

I figured out that the mnemonic "E" is being chosen by Windows because we did not provide a mnemonic ourselves. I think setting the mnemonic key to the space character would avoid most accidental edits in this context.

Fred57

Fred57

2019-08-13 19:57

reporter   ~0004007

Perhaps the messageBox should not give the possibility to activate a record session so the E key will not affect this. A WarningMessage 'click on the record button if you want to activate a record' with a simple OK button could perhaps solve the problem.

Saga Musix

Saga Musix

2019-08-13 19:58

administrator   ~0004008

As said, I could offer to change the mnemonic key from E to Space. Even if there was an OK button it could still be triggered with the space bar, so you wouldn't gain anything.

Saga Musix

Saga Musix

2019-08-22 19:53

administrator   ~0004016

The mnemonic character has now been modified so that the popup can no longer be dismissed with one accidental keypress. If you change OpenMPT's update channel to "next", you should receive an update with the fix by tomorrow. Alterantively, build r11932 will be available from https://builds.openmpt.org/builds/ within the next few hours.

Issue History

Date Modified Username Field Change
2019-08-13 15:04 Fred57 New Issue
2019-08-13 16:02 Saga Musix Note Added: 0004005
2019-08-13 17:06 Saga Musix Note Added: 0004006
2019-08-13 18:34 Fred57 Description Updated View Revisions
2019-08-13 19:57 Fred57 Note Added: 0004007
2019-08-13 19:58 Saga Musix Note Added: 0004008
2019-08-22 19:53 Saga Musix Note Added: 0004016
2019-08-22 19:53 Saga Musix Assigned To => Saga Musix
2019-08-22 19:53 Saga Musix Status new => assigned
2019-08-22 19:54 Saga Musix Status assigned => resolved
2019-08-22 19:54 Saga Musix Resolution open => fixed
2019-08-22 19:54 Saga Musix Fixed in Version => OpenMPT 1.28.07.00 / libopenmpt 0.4.7 (upgrade first)
2019-08-22 19:54 Saga Musix Target Version => OpenMPT 1.28.07.00 / libopenmpt 0.4.7 (upgrade first)