View Issue Details

IDProjectCategoryView StatusLast Update
0001225OpenMPT[All Projects] Accessibilitypublic2019-05-29 17:46
Reportera11cf0Assigned ToSaga Musix 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product VersionOpenMPT 1.29.00.* (current testing) 
Target VersionOpenMPT 1.28.06.00 / libopenmpt 0.4.6 (upcoming stable)Fixed in VersionOpenMPT 1.28.06.00 / libopenmpt 0.4.6 (upcoming stable) 
Summary0001225: Focus position isn't remembered when navigating folders in the main treeview
Description

In the lower half of the main treeview, when navigating folders with the keyboard, the focus position is never remembered.
This is especially noticeable when pressing backspace to go to the parent folder. So, when doing this the focus always jumps to the top of the folder list.
It would be great if the focus position can be correctly restored in such cases. This will make keyboard navigation in this treeview more efficient.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2019-05-28 20:07

administrator   ~0003956

r11630 should fix this when showing folders in the lower tree view (it already worked as intended in the upper tree view). It will be available in a few hours from https://builds.openmpt.org/builds/

This is especially noticeable when pressing backspace to go to the parent folder.

For the reference, in which other situations would you expect the selection to differ?

a11cf0

a11cf0

2019-05-29 08:30

reporter   ~0003957

Thanks. Now everything is working as expected.

Issue History

Date Modified Username Field Change
2019-05-11 20:33 a11cf0 New Issue
2019-05-22 20:27 Saga Musix Assigned To => Saga Musix
2019-05-22 20:27 Saga Musix Status new => assigned
2019-05-28 20:07 Saga Musix Note Added: 0003956
2019-05-28 20:07 Saga Musix Status assigned => feedback
2019-05-28 20:08 Saga Musix Target Version => OpenMPT 1.28.06.00 / libopenmpt 0.4.6 (upcoming stable)
2019-05-29 08:30 a11cf0 Note Added: 0003957
2019-05-29 08:30 a11cf0 Status feedback => assigned
2019-05-29 17:46 Saga Musix Status assigned => resolved
2019-05-29 17:46 Saga Musix Resolution open => fixed
2019-05-29 17:46 Saga Musix Fixed in Version => OpenMPT 1.28.06.00 / libopenmpt 0.4.6 (upcoming stable)