View Issue Details

IDProjectCategoryView StatusLast Update
0001216OpenMPT[All Projects] Audio I/Opublic2019-04-07 13:30
ReporterMiniMacro Assigned ToSaga Musix  
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version10
Product VersionOpenMPT 1.28.01.00 / libopenmpt 0.4.0 (upgrade first) 
Target VersionOpenMPT 1.28.04.00 / libopenmpt 0.4.4 (upgrade first)Fixed in VersionOpenMPT 1.28.04.00 / libopenmpt 0.4.4 (upgrade first) 
Summary0001216: .mod file keeps corrupting my .wav samples
Description

whenever i make a new .mod module, and i load in samples in .wav form, the samples become white noise after closing and reopening the module even if i have not edited the sample inside openmpt directly

Steps To Reproduce
  1. create new .mod
  2. load in .wav samples
  3. save module
  4. close module
  5. reopen module and the samples will have become white noise
Additional Information

https://drive.google.com/file/d/1_Mn1DIHViIiH0i3CheKM3WeKaiH4ESe-/view?usp=sharing
the files are in this link because they exceed the filesize limit
there are two modules contained here, a .mod which has the corrupted samples, and an .xm which has the samples as they are intended to sound (and did in the .mod before i closed and reopened the .mod)

TagsNo tags attached.
Has the bug occurred in previous versions?i do not know
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2019-03-31 11:39

administrator   ~0003905

Thanks for providing the example file. This only happens with 16-bit samples, but of course it shouldn't (and in the past it didn't). Will be fixed in the next release.

Saga Musix

Saga Musix

2019-03-31 12:09

administrator   ~0003906

Should be fixed in r11499. You can download it in a few hours from https://builds.openmpt.org/builds/auto/openmpt/bin.win64/1.28/ to verify.

MiniMacro

MiniMacro

2019-03-31 12:11

reporter   ~0003907

ah, thanks!

Issue History

Date Modified Username Field Change
2019-03-31 11:31 MiniMacro New Issue
2019-03-31 11:38 Saga Musix Assigned To => Saga Musix
2019-03-31 11:38 Saga Musix Status new => assigned
2019-03-31 11:38 Saga Musix Target Version => OpenMPT 1.28.04.00 / libopenmpt 0.4.4 (upgrade first)
2019-03-31 11:39 Saga Musix Note Added: 0003905
2019-03-31 12:09 Saga Musix Status assigned => feedback
2019-03-31 12:09 Saga Musix Note Added: 0003906
2019-03-31 12:11 MiniMacro Note Added: 0003907
2019-03-31 12:11 MiniMacro Status feedback => assigned
2019-03-31 12:27 Saga Musix Status assigned => feedback
2019-04-07 13:30 Saga Musix Status feedback => resolved
2019-04-07 13:30 Saga Musix Resolution open => fixed
2019-04-07 13:30 Saga Musix Fixed in Version => OpenMPT 1.28.04.00 / libopenmpt 0.4.4 (upgrade first)