View Issue Details

IDProjectCategoryView StatusLast Update
0001213OpenMPTGeneralpublic2020-06-07 07:30
Reportermanx Assigned Tomanx  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product VersionOpenMPT 1.29.00.* (old testing) 
Target VersionOpenMPT 1.30 / libopenmpt 0.6 (goals)Fixed in VersionOpenMPT 1.30 / libopenmpt 0.6 (goals) 
Summary0001213: Admin-level installer modifies per-user directories
Description

This should not happen at all because it is the wrong thing to do. Installing software system-wide should never result in a different outcome for the one user who did the install compared to all other users on the system
InnoSetup even warns about this fact:

Warning: The [Setup] section directive "PrivilegesRequired" is set to "admin" but per-user areas (userappdata,userdesktop,userprograms) are used by the script. Regardless of the version of Windows, if the installation is administrative then you should be careful about making any per-user area changes: such changes may not achieve what you are intending. See the help file for more information.
TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Relationships

related to 0001011 assignedmanx Automatic update 
related to 0001123 resolvedmanx Provide unified multi-arch installer 
related to 0000649 resolvedmanx modern file type registration (was: Re-register MPT instantly

Activities

Saga Musix

Saga Musix

2019-03-09 22:58

administrator   ~0003893

InnoSetup 6 will make this considerably easier. I'd defer this change until we upgrade to IS6 (i.e. keep the current behaviour for OpenMPT 1.28 as noone ever complained about it)

mavhc

mavhc

2019-11-26 18:57

reporter   ~0004158

I noticed it's installing Start Menu links for the current user too (in my case System, because installing from a startup script). Look forward to the new version, thanks.

manx

manx

2020-06-07 07:30

administrator   ~0004371

r12991 / 1.30.00.04

Issue History

Date Modified Username Field Change
2019-03-08 12:55 manx New Issue
2019-03-08 12:55 manx Relationship added related to 0001011
2019-03-08 12:55 manx Relationship added related to 0001123
2019-03-08 12:56 manx Relationship added related to 0000649
2019-03-09 22:58 Saga Musix Note Added: 0003893
2019-11-26 18:57 mavhc Note Added: 0004158
2020-04-14 16:20 manx Target Version OpenMPT 1.29.01.00 / libopenmpt 0.5.0 (current stable) => OpenMPT 1.30 / libopenmpt 0.6 (goals)
2020-05-10 09:04 manx Status new => acknowledged
2020-06-07 07:30 manx Assigned To => manx
2020-06-07 07:30 manx Status acknowledged => resolved
2020-06-07 07:30 manx Resolution open => fixed
2020-06-07 07:30 manx Fixed in Version => OpenMPT 1.30 / libopenmpt 0.6 (goals)
2020-06-07 07:30 manx Note Added: 0004371