View Issue Details

IDProjectCategoryView StatusLast Update
0001211OpenMPT[All Projects] User Interfacepublic2019-03-05 07:40
ReporterfunuteAssigned Tomanx 
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformwine-4.2OSArch LinuxOS VersionLinux 4.20.13
Product VersionOpenMPT 1.28.03.00 / libopenmpt 0.4.3 (upgrade first) 
Target VersionFixed in VersionOpenMPT 1.28.04.00 / libopenmpt 0.4.4 (upgrade first) 
Summary0001211: RtAudio option in OpenMPT Setup Wine dialog uses value for PortAudio option
Description

Found this issue while messing around with the dialog in looking at https://bugs.openmpt.org/view.php?id=1210. The option for RtAudio is set to the option for PortAudio whenever opening the dialog. (I think the value is still saved to whatever it's set to when you OK/Apply out of the dialog, but not sure.)

I've attached a patch which I think should fix the issue, haven't tested or confirmed it for myself since I don't think I can build a mptrack Windows binary from Linux.

Steps To Reproduce
  1. Enable Wine integration via OpenMPT Setup > Wine > Check "Enable Wine native host support (requires restarting OpenMPT)"
  2. Set PortAudio and RtAudio to different settings
  3. Press OK to save the settings and close the dialog
  4. Open the OpenMPT Setup dialog again
  5. The RtAudio option will show whatever value you set for PortAudio before instead of the value you set for RtAudio before
TagsNo tags attached.
Has the bug occurred in previous versions?Unsure
Tested code revision (in case you know it)

Activities

funute

funute

2019-03-05 04:51

reporter  

patch.diff (600 bytes)
Index: mptrack/Mpdlgs.cpp
===================================================================
--- mptrack/Mpdlgs.cpp	(revision 11422)
+++ mptrack/Mpdlgs.cpp	(working copy)
@@ -1862,7 +1862,7 @@
 	index = m_CbnRtAudio.AddString(_T("Disabled")); m_CbnRtAudio.SetItemData(index, 0);
 	for(index = 0; index < 3; ++index)
 	{
-		if(m_CbnRtAudio.GetItemData(index) == static_cast<uint32>(TrackerSettings::Instance().WineSupportEnablePortAudio))
+		if(m_CbnRtAudio.GetItemData(index) == static_cast<uint32>(TrackerSettings::Instance().WineSupportEnableRtAudio))
 		{
 			m_CbnRtAudio.SetCurSel(index);
 		}
patch.diff (600 bytes)
manx

manx

2019-03-05 07:40

administrator   ~0003888

Thanks. Patch applied as r11423 (1.29) and r11424 (1.28).

Issue History

Date Modified Username Field Change
2019-03-05 04:51 funute New Issue
2019-03-05 04:51 funute File Added: patch.diff
2019-03-05 07:31 manx Assigned To => manx
2019-03-05 07:31 manx Status new => assigned
2019-03-05 07:40 manx Status assigned => resolved
2019-03-05 07:40 manx Resolution open => fixed
2019-03-05 07:40 manx Fixed in Version => OpenMPT 1.28.04.00 / libopenmpt 0.4.4 (upgrade first)
2019-03-05 07:40 manx Note Added: 0003888