View Issue Details

IDProjectCategoryView StatusLast Update
0001201OpenMPT[All Projects] Playback Compatibilitypublic2019-02-25 19:02
ReportercspiegelAssigned ToSaga Musix 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx86_64OSLinuxOS Version4.20.10
Product VersionOpenMPT 1.28.03.00 / libopenmpt 0.4.3 (upgrade first) 
Target VersionOpenMPT 1.28.04.00 / libopenmpt 0.4.4 (current stable)Fixed in VersionOpenMPT 1.28.04.00 / libopenmpt 0.4.4 (current stable) 
Summary0001201: Possible playback bug with specific module
Description

The module "gunnars staalvaerk" (https://modarchive.org/index.php?request=view_by_moduleid&query=106439) is reported by libopenmpt to be 7:48 long, whereas other players I've tried (xmp, modplug, ocp) peg it at around 2:24. At the 2:24 mark, with libopenmpt, there is silence, but the module continues to play till the 7:48 mark.

I'm not sure if this is a bug in libopenmpt, but since it differs from other players, I thought it was worth reporting.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2019-02-25 18:47

administrator   ~0003863

This is a Startrekker module, and Startrekker only supports VBlank timing (i.e. tempo commands above F1F are treated as ticks per rows). The other players you tested do not seem to respect this and set speed instead of ticks per row on the last pattern. However, after reading the Startrekker replayer code, it seems like Startrekker actually clamps the ticks per row to 1F, so the correct song length is about 3 minutes.

Saga Musix

Saga Musix

2019-02-25 19:02

administrator   ~0003864

This is fixed in r11396. As described above, it won't produce the same output as those other libraries as they are also wrong.

Issue History

Date Modified Username Field Change
2019-02-25 18:37 cspiegel New Issue
2019-02-25 18:44 Saga Musix Assigned To => Saga Musix
2019-02-25 18:44 Saga Musix Status new => assigned
2019-02-25 18:47 Saga Musix Note Added: 0003863
2019-02-25 19:02 Saga Musix Note Added: 0003864
2019-02-25 19:02 Saga Musix Status assigned => resolved
2019-02-25 19:02 Saga Musix Resolution open => fixed
2019-02-25 19:02 Saga Musix Fixed in Version => OpenMPT 1.28.04.00 / libopenmpt 0.4.4 (current stable)
2019-02-25 19:02 Saga Musix Target Version => OpenMPT 1.28.04.00 / libopenmpt 0.4.4 (current stable)