View Issue Details

IDProjectCategoryView StatusLast Update
0001200OpenMPT[All Projects] Feature Requestpublic2019-02-26 21:37
ReporterExpanding Assigned ToSaga Musix  
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Platformx86OSWindowsOS Version7
Product VersionOpenMPT 1.28.03.00 / libopenmpt 0.4.3 (upgrade first) 
Target VersionOpenMPT 1.28.04.00 / libopenmpt 0.4.4 (upgrade first)Fixed in VersionOpenMPT 1.28.04.00 / libopenmpt 0.4.4 (upgrade first) 
Summary0001200: 1/96th MIDI File Import Notes Quantize
Description

It would be really nice if the specific Quantize 1/96th Notes option for MIDI Import was provided.

Sometimes, it is really useful being able to import patterns in the form of MIDI files. However OpenMPT's MIDI File Import feature doesn't support Notes 3/4 time quantization, so the feature is rather useless if the notes in the pattern are based on 3/4 time.
Importing MIDI files with notes quantized to 1/96th grid can result in long patterns of 96 rows: that's exactly what I need.

Thank you very much. Love making music with OpenMPT.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2019-02-25 10:51

administrator   ~0003862

There are two separate issues here at hands:

  1. 3/4 time signature. OpenMPT will always import MIDI files as 4/4 because supporting different or more than one time signature in MIDI import would add a lot complexity than I'm comfortable with to add.
  2. Quantization: I guess it would make sense to add 24th, 48th and maybe 96th quantization to address your problem. But note that you can already choose any quantization amount you like by going to the Advanced Settings and setting the MidiImportQuantize option to the desired value. 96 seems a bit excessive for most files, maybe try 48 first.
Expanding

Expanding

2019-02-25 22:12

reporter   ~0003865

Setting the value of MidiImportQuantize is what I needed.

I definitely need to work with pattern data that determines note information up to 1/96ths while running every row as a single tick.
I failed before to notice MidiImportQuantize in the value list; my bad, sorry.

Thank you so much for the response.

Saga Musix

Saga Musix

2019-02-26 21:36

administrator   ~0003866

I have added 1/6th, 1/12th, 1/24th, 1/48th and 1/96th to the options for the next release.

Issue History

Date Modified Username Field Change
2019-02-25 07:40 Expanding New Issue
2019-02-25 10:51 Saga Musix Note Added: 0003862
2019-02-25 22:12 Expanding Note Added: 0003865
2019-02-26 21:36 Saga Musix Note Added: 0003866
2019-02-26 21:37 Saga Musix Assigned To => Saga Musix
2019-02-26 21:37 Saga Musix Status new => resolved
2019-02-26 21:37 Saga Musix Resolution open => fixed
2019-02-26 21:37 Saga Musix Fixed in Version => OpenMPT 1.28.04.00 / libopenmpt 0.4.4 (upgrade first)
2019-02-26 21:37 Saga Musix Target Version => OpenMPT 1.28.04.00 / libopenmpt 0.4.4 (upgrade first)