View Issue Details

IDProjectCategoryView StatusLast Update
0001095OpenMPT[All Projects] File Format Supportpublic2018-05-28 18:05
ReportermanxAssigned Tomanx 
PrioritylowSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Product VersionOpenMPT 1.28.00.* (current testing) 
Target VersionOpenMPT 1.28.01.00 (goals)Fixed in VersionOpenMPT 1.28.01.00 (goals) 
Summary0001095: Ship LAME MP3 encoder
Description

We should consider also shipping MP3 encoding by now, as all patents have clearly expired, even by the most pessimistic interpretation.

Shipping LAME would allow us to completely remove the ACM MP3 encoding code.

Additional Information

https://www.loc.gov/preservation/digital/formats/fdd/fdd000012.shtml
https://madfileformatscience.garymcgath.com/2017/04/14/mp3-freedom/
http://www.tunequest.org/a-big-list-of-mp3-patents/20070226/
https://madfileformatscience.garymcgath.com/2017/04/19/mp3-patent-holders/
https://madfileformatscience.garymcgath.com/2017/04/20/mp3-april-23/
https://en.wikipedia.org/wiki/MP3#Licensing,_ownership_and_legislation

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Relationships

related to 0001113 new Avoid delay-loading of libraries that we ship 

Activities

manx

manx

2018-05-28 16:18

administrator   ~0003536

It's been over a year now since all patents have expired.

Reaper is shipping LAME since v5.50 (2017-09-16).
Even Fedora (since v27 (2017-11-14)) is shipping it.
We should do so as well.

manx

manx

2018-05-28 18:05

administrator   ~0003538

r10313, r10314, r10315, r10316, r10317, r10318, r10319, r10320 (1.28.00.21)

Issue History

Date Modified Username Field Change
2018-02-25 12:28 manx New Issue
2018-02-25 12:28 manx Status new => assigned
2018-02-25 12:28 manx Assigned To => manx
2018-05-28 16:18 manx Note Added: 0003536
2018-05-28 16:18 manx Target Version OpenMPT 1.?? (long term goals) => OpenMPT 1.28.01.00 (goals)
2018-05-28 18:03 manx Relationship added related to 0001113
2018-05-28 18:05 manx Status assigned => resolved
2018-05-28 18:05 manx Resolution open => fixed
2018-05-28 18:05 manx Fixed in Version => OpenMPT 1.28.01.00 (goals)
2018-05-28 18:05 manx Note Added: 0003538