View Issue Details

IDProjectCategoryView StatusLast Update
0000979OpenMPT[All Projects] Generalpublic2017-08-01 15:09
Reporter404notfoundAssigned ToSaga Musix 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Platformx86OSWindowsOS VersionXP
Product VersionOpenMPT 1.27.00.* (current testing) 
Target VersionOpenMPT 1.27.01.00 (upcoming stable)Fixed in VersionOpenMPT 1.27.01.00 (upcoming stable) 
Summary0000979: BLEP malfunction during playback
Description

BLEP resampler seems to turn into a lowpass filter, on and off during playback. Files attached.
Recording: https://a.pomf.cat/dzvtwa.ogg

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

404notfound

404notfound

2017-06-15 12:14

reporter  

naen_leijasi.zip (36,640 bytes)
Saga Musix

Saga Musix

2017-06-15 12:34

administrator   ~0003084

The module contains E0x effects for enabling/disabling the LED filter. They have probably not been placed intentionally but since any E0x parameter is valid for setting the filter, we cannot do much about it. There are modules that disable the LED filter multiple times per pattern so we also cannot use a heuristic like "filter is being turned on/off several times". You will have to disable the Amiga Resampler for this particular module.

Saga Musix

Saga Musix

2017-07-30 19:48

administrator   ~0003122

I really wanted to avoid this but I added a new heuristic in r8672 which disables the Amiga Resampler for modules that have too many LED Filter state transitions, like the one provided here.

Issue History

Date Modified Username Field Change
2017-06-15 12:14 404notfound New Issue
2017-06-15 12:14 404notfound File Added: naen_leijasi.zip
2017-06-15 12:34 Saga Musix Note Added: 0003084
2017-06-15 12:35 Saga Musix Status new => closed
2017-06-15 12:35 Saga Musix Resolution open => no change required
2017-07-30 19:48 Saga Musix Status closed => resolved
2017-07-30 19:48 Saga Musix Resolution no change required => fixed
2017-07-30 19:48 Saga Musix Fixed in Version => OpenMPT 1.27.01.00 (upcoming stable)
2017-07-30 19:48 Saga Musix Target Version => OpenMPT 1.27.01.00 (upcoming stable)
2017-07-30 19:48 Saga Musix Note Added: 0003122
2017-08-01 15:09 Saga Musix Assigned To => Saga Musix