View Issue Details

IDProjectCategoryView StatusLast Update
0000977OpenMPT[All Projects] Feature Requestpublic2017-06-12 13:46
Reporter404notfoundAssigned To 
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionwon't fix 
Platformx86OSWindowsOS VersionXP
Product VersionOpenMPT 1.27.00.* (current testing) 
Target VersionFixed in Version 
Summary0000977: Amiga resampler as ordinary resampler option
Description

Requesting BLEP as ordinary option in resampler menu, readily selectable regardless of format.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2017-06-12 13:45

administrator   ~0003075

Last edited: 2017-06-12 13:46

View 2 revisions

No, it is fully intentional that it's not available for non-Amiga formats. The resampler only works as intended within the Amiga limitations, it degrades the quality of 16-bit samples and is not implemented for stereo samples.
If you need something similar in other formats, you can apply a lowpass filter as a global effect to at least emulate the lowpass effect of the resampler.

Issue History

Date Modified Username Field Change
2017-06-12 13:42 404notfound New Issue
2017-06-12 13:45 Saga Musix Status new => closed
2017-06-12 13:45 Saga Musix Resolution open => won't fix
2017-06-12 13:45 Saga Musix Note Added: 0003075
2017-06-12 13:46 Saga Musix Note Edited: 0003075 View Revisions