View Issue Details

IDProjectCategoryView StatusLast Update
0000975OpenMPT[All Projects] Generalpublic2017-07-02 15:49
ReporterVinCMGAssigned ToSaga Musix 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx86 / x64OSWineOS Version1.6.2
Product VersionOpenMPT 1.26.11.00 / libopenmpt 0.2-beta24 (upgrade first) 
Target VersionOpenMPT 1.26.12.00 / libopenmpt 0.2-beta26 (upgrade first)Fixed in VersionOpenMPT 1.26.12.00 / libopenmpt 0.2-beta26 (upgrade first) 
Summary0000975: XM volume column effects accessible in MPTM
Description

When editing an MPTM file, it is possible to place XM format's lxx and rxx panning slide effects in the volume column even though they are not MPTM effects. Playback is mirrored (lxx slides to the right and rxx to the left) but otherwise seems to work. Once the file is closed and reopened, they disappear.

Edit: After playing around a bit more, I was also able to put down uxx commands, but instead of disappearing they turn into Hxx's when I close and reopen the module.

Steps To Reproduce

Open any MPTM file.
Add a few lxx/rxx commands in any volume column.
Save and close the file.
Reopen the file.

Additional Information

The screenshot in the uploaded zip shows what the module looked like when I saved it.

TagsNo tags attached.
Has the bug occurred in previous versions?Yes; at least as far back as 1.26.10.00
Tested code revision (in case you know it)

Activities

VinCMG

VinCMG

2017-06-12 05:00

reporter  

xm effects in mptm.zip (12,135 bytes)
Saga Musix

Saga Musix

2017-06-12 17:00

administrator   ~0003078

Fixed in r8310. Funnily enough, in XM it was also possible to enter commands e/f but of course they couldn't be saved. I thought about allowing those effects in MPTM but since the space for new volume commands is limited (only two more can be added), I decided against it. We might want to add a more useful command later.

Issue History

Date Modified Username Field Change
2017-06-12 05:00 VinCMG New Issue
2017-06-12 05:00 VinCMG File Added: xm effects in mptm.zip
2017-06-12 05:08 VinCMG Description Updated View Revisions
2017-06-12 08:58 Saga Musix Assigned To => Saga Musix
2017-06-12 08:58 Saga Musix Status new => assigned
2017-06-12 17:00 Saga Musix Note Added: 0003078
2017-06-12 17:00 Saga Musix Status assigned => resolved
2017-06-12 17:00 Saga Musix Resolution open => fixed
2017-06-12 17:00 Saga Musix Fixed in Version => OpenMPT 1.27.01.00 / libopenmpt 0.3.1 (current stable)
2017-06-12 17:00 Saga Musix Target Version => OpenMPT 1.27.01.00 / libopenmpt 0.3.1 (current stable)
2017-07-02 15:49 Saga Musix Fixed in Version OpenMPT 1.27.01.00 / libopenmpt 0.3.1 (current stable) => OpenMPT 1.26.12.00 / libopenmpt 0.2-beta26 (upgrade first)
2017-07-02 15:49 Saga Musix Target Version OpenMPT 1.27.01.00 / libopenmpt 0.3.1 (current stable) => OpenMPT 1.26.12.00 / libopenmpt 0.2-beta26 (upgrade first)