View Issue Details

IDProjectCategoryView StatusLast Update
0000940OpenMPT[All Projects] User Interfacepublic2017-04-09 13:16
ReporterWoddAssigned To 
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionduplicate 
Platformx64OSWindowsOS Version10
Product VersionOpenMPT 1.26.08.00 / libopenmpt 0.2-beta20.5 (upgrade first) 
Target VersionFixed in Version 
Summary0000940: Samples Tab Not Updating Properly
Description

I have noticed that the Samples tab includes a white line to indicate where the playback is currently within a sample. But, sometimes I don't see it. I am guessing that I should.

Steps To Reproduce
  1. Create a new module.
  2. From the General tab, decrease the channel quantity to 2 (although any number might work).
  3. Navigate to the Samples tab.
  4. Load Alienware + Taste + Weird (downloadable from https://onedrive.live.com/?id=BD6492FE45944E%21116&cid=00BD6492FE45944E ).
  5. Navigate to the Patterns tab.
  6. Place a note (I used C-5) in each of the channels.
  7. Mute one of the channels.
  8. Navigate back to the Samples tab.
  9. Activate the play song from start function.
    At this point, you should see a white line on the sample that moves as the sample plays.
  10. Navigate back to the Patterns tab.
  11. Unmute the muted channel.
  12. Navigate back to the Samples tab.
  13. Activate the play song from start function.
    At this point, you should not see the white line.
  14. If you have only one pattern (0), create more patterns either by creating new ones or duplicating pattern 0.
  15. Navigate to anywhere within one of the newly added patterns.
  16. Navigate to the Samples tab.
  17. Activate the play song from cursor function.
    You should notice that the white line does not appear. This works with one or both channels unmuted. Using the play pattern from start and play pattern from cursor functions also does not show the white line, whether one channel is or both channels are unmuted.
TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)revision 7518 (64-bit)

Relationships

duplicate of 0000074 closedSaga Musix View Sample While Playing Song 

Activities

Saga Musix

Saga Musix

2017-04-09 13:16

administrator   ~0002972

You already reported this before, and I explained why this happens in the duplicate issue. Instead of playing the same sample twice, it's better to just play all other samples at half volume, anyway.

Issue History

Date Modified Username Field Change
2017-04-09 06:57 Wodd New Issue
2017-04-09 13:15 Saga Musix Relationship added duplicate of 0000074
2017-04-09 13:16 Saga Musix Status new => closed
2017-04-09 13:16 Saga Musix Resolution open => duplicate
2017-04-09 13:16 Saga Musix Note Added: 0002972