View Issue Details

IDProjectCategoryView StatusLast Update
0000074OpenMPT[All Projects] Feature Requestpublic2017-04-09 13:15
ReporterReally Weird PersonAssigned ToSaga Musix 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionno change required 
Platformx64OSWindowsOS Version7
Product VersionOpenMPT 1.19.00.* (old testing) 
Target VersionFixed in Version 
Summary0000074: View Sample While Playing Song
Description

It want due great to be able to watch samples from the Samples tab as the song is playing. What I mean is this: When on the Samples tab, if a note key is pressed, a white navigation/seek line appears over the sample. It would be great to see this occur with all active samples even while the song is playing (via pressing the key on a keyboard assigned to the play function or clicking or tapping one of the Play triangles).

Additional Information

It seems that it dees happen (the seek-like line appearing on the samples tab while the song is playing). It does not seem to happen with all samples though.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Relationships

has duplicate 0000940 closed Samples Tab Not Updating Properly 

Activities

Really Weird Person

Really Weird Person

2011-02-15 05:10

reporter   ~0000065

Correction: It would be great…
Apparently 1. the words were changed half-way through the sentence or 2. my handwriting was misinterpreted and I did not notice it.

Saga Musix

Saga Musix

2011-02-15 10:43

administrator   ~0000067

So where is your suggestion? All samples triggered are displayed as playing samples in the sample editor. If a sample is triggered twice and playing at exactly the same speed, you won't see anything because the "white line" just inverts the colours, and inverting colours twice will look as if there was no line. Can't fix that.

Issue History

Date Modified Username Field Change
2011-02-15 05:02 Really Weird Person New Issue
2011-02-15 05:10 Really Weird Person Note Added: 0000065
2011-02-15 10:43 Saga Musix Note Added: 0000067
2011-02-15 10:43 Saga Musix Status new => closed
2011-02-15 10:43 Saga Musix Assigned To => Saga Musix
2011-02-15 10:43 Saga Musix Resolution open => no change required
2017-04-09 13:15 Saga Musix Relationship added has duplicate 0000940