View Issue Details

IDProjectCategoryView StatusLast Update
0000937OpenMPT[All Projects] Plugins / VSTpublic2017-04-05 13:01
ReporterruinatokyoAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Platformx64OSWindowsOS Version10
Product VersionOpenMPT 1.26.09.00 / libopenmpt 0.2-beta22 (upgrade first) 
Target VersionFixed in Version 
Summary0000937: "File is not a valid plugin" error and others on multiple working VST plugins
Description

All of these plugins worked on my Windows 7 (Japanese region) machine. I reinstalled them on Windows 10 x64 (Japanese region) and while they work in my DAWs, OpenMPT throws an error: "File is not a valid plugin. Do you want to try to load the plugin natively?" Trying to load it natively, bridged, etc., does not help the situation. I am using the same MPT version, same DAW versions, same plugin versions, etc. as the Windows 7 machine. The only change is the OS.

Unfortunately for testing, the plugins that cause the error are all paid plugins. Some of those are: izotope alloy 2, izotope ozone 5, izotope ozone 7, miroslav philharmonik, Exp Digital GFlux, audio damage kombinat, lexicon psp 4.2, and korg midi filter.

As for free plugins, Massey demos (https://www.masseyplugins.com/demo) come up with a "module could not be found" error instead. A few others state something like "error initializing dll". And yet others come up with a window from the VST saying it is unlicensed and asking for registration info, yet the VSTs are licensed/registered, and those windows don't come up from my DAWs (reaper and cubase).

Additional Information

One thing I noticed is, for example, while the plugin is massive, the miroslav philharmonik dll is only about 120KB, so could it be a matter of the dll pointing to another file?

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2017-04-03 23:16

administrator   ~0002958

Last edited: 2017-04-03 23:17

View 2 revisions

Did you reinstall the plugins properly? Many of those plugins won't work if you just copy them from your old Windows 7 installation.
Also verify that the plugins work in any other host, e.g. this one: http://www.hermannseib.com/english/vsthost.htm

Midori

Midori

2017-04-04 14:22

reporter   ~0002959

Some plugins store their config and/or licensing information in OS's registry, or user data directories (%appdata%, etc), and depending on how you installed the new OS/migrated old data those plugins might refuse to work properly, but it's a bit puzzling they work OOB with other DAWs... I might be missing something here...

ruinatokyo

ruinatokyo

2017-04-05 12:20

reporter   ~0002962

Sorry for the late reply.

I reinstalled them rather than copy them over. Same with OpenMPT. The plugins work in the other DAWs. I tried uninstalling and reinstalling OpenMPT, and trying the 32-bit and 64-bit versions of OpenMPT.

I just tried the vst host at http://www.hermannseib.com/english/vsthost.htm

It crashed on scanning through the plugins. I tried to load the problem VSTs one-by-one and it just simply didn't add some of them, while it did add the non-problem plugins and some of the OpenMPT problem-plugins (it loaded audio damage kombinat fine while OpenMPT did not).

I am trying to release a CD in May, so Miroslav Philharmonik is the main issue. But neither OpenMPT nor the above VST host loaded it.

Saga Musix

Saga Musix

2017-04-05 12:31

administrator   ~0002963

The fact that both OpenMPT and Hermann Seib's host have random problems seems to indicate that it's not an issue with OpenMPT itself but rather something more complicated than that, possibly related to Windows 10.
I tried the Massey link by the way and it says "Sorry, Massey Plugins doesn't make VST or AU plugins." Only ProTools plugins seem to be available there, which are of course not compatible with VST hosts.

ruinatokyo

ruinatokyo

2017-04-05 12:43

reporter   ~0002964

I am figuring it is a Win10 issue (or Win10 Japanese issue, you'd be surprised how many applications that breaks).

Unfortunately I guess Massey stopped doing the VST demos. I have them installed and they are great.

I guess I'll run a vbox to deal with it in the meanwhile.

Thanks!

Saga Musix

Saga Musix

2017-04-05 12:44

administrator   ~0002965

It's not something you should normally do, but does running OpenMPT in administrator mode help maybe?

ruinatokyo

ruinatokyo

2017-04-05 12:47

reporter   ~0002966

Wow, yes. they load with OpenMPT in admin mode!

Saga Musix

Saga Musix

2017-04-05 13:00

administrator   ~0002967

It's possible that it's only necessary to do this once and then run OpenMPT without admin privileges (for some plugins this is the case). Anyway, it's quite clearly a permission issue then, which may or may not be solvable by re-installing the plugins in question (re-installing OpenMPT won't help). I don't think there is anything that could be done from our side.

Issue History

Date Modified Username Field Change
2017-04-03 23:15 ruinatokyo New Issue
2017-04-03 23:16 Saga Musix Note Added: 0002958
2017-04-03 23:17 Saga Musix Note Edited: 0002958 View Revisions
2017-04-04 14:22 Midori Note Added: 0002959
2017-04-05 12:20 ruinatokyo Note Added: 0002962
2017-04-05 12:31 Saga Musix Note Added: 0002963
2017-04-05 12:43 ruinatokyo Note Added: 0002964
2017-04-05 12:44 Saga Musix Note Added: 0002965
2017-04-05 12:47 ruinatokyo Note Added: 0002966
2017-04-05 13:00 Saga Musix Note Added: 0002967
2017-04-05 13:01 Saga Musix Status new => closed
2017-04-05 13:01 Saga Musix Resolution open => no change required