View Issue Details

IDProjectCategoryView StatusLast Update
0000088OpenMPT[All Projects] Feature Requestpublic2012-11-13 22:33
ReporterReally Weird PersonAssigned ToSaga Musix 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version7
Product VersionOpenMPT 1.19.00.* (old testing) 
Target VersionOpenMPT 1.20.04.00 (upgrade first)Fixed in VersionOpenMPT 1.20.04.00 (upgrade first) 
Summary0000088: Add Samples and Instruments Before or After Current Sample or Instrument
Description

I think that I have posted this one before, but that was before the issue tracker was established. It would be nice to be able to add a sample or an instrument after or before the current sample or instrument instead of them always being added to the end. I see one of at least two options for this function.

  1. In the context menu (accessed via pressing the right mouse button) in the tree, add the option to add a sample or instrument before or after the one that was clicked.
  2. When clicking the New Sample or New Instrument, display a dialog with the option to add a sample or an instrument at the end, before the current sample or instrument, or after the current sample or instrument.
TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Relationships

related to 0000030 resolvedSaga Musix Be able to change the order of a sample or instrument number 

Activities

Saga Musix

Saga Musix

2012-10-21 15:30

administrator   ~0000913

Here's something to try... From the treeview, it is now possible to rearrange samples and instruments using drag&drop, and you can also insert and duplicate them through the context menu. http://sagagames.de/stuff/mptrack.exe

Saga Musix

Saga Musix

2012-11-11 16:48

administrator   ~0000925

Reminder sent to: Really Weird Person

So, any comments on whether this works as intended or not?

Really Weird Person

Really Weird Person

2012-11-11 22:42

reporter   ~0000929

Last edited: 2012-11-13 11:05

View 5 revisions

I haven't tried. I reconfigured the RAID configuration on my computer (from RAID 5 to RAID 1 + 0) (due to an unacceptable performance drop). As I am writing this message, Windows 8 is bling installed on it. Have you used Windows 8? It is fun to use on a tablet PC (although it is being instated on my desktop right now). My previous tablet PC died so I am using one of Wacom's Bamboo Create tablets connected to a conventional laptop. The tablet PCs that I am looking at (ruggedized ones by Motion Computing) cost over $4,000, so I might not be getting one until either Christmastime or my birthday (February 26th). In case you are unfamiliar with RAID, you can read about it on Wikipedia (http://en.wikipedia.org/wiki/RAID).
I tested the sample and instrument movement and it does work. There seems to be a bug, however. Here is what I did.
Method 1:

  1. Create a new module (.it format).
  2. Insert multiple samples (I used 27, but the number probably doesn't matter).
  3. Insert a note (I used C-5.)
  4. Move one of the samples (I moved it to the top.)
  5. Hover over the Main Instrument drop down list. It should update.
  6. Hover over the pattern editor. You should see the number 1 change to 255.
    Method 2: The steps above, but using the Instruments tab rather than the samples tab. The difference is that hovering over the pattern editor should cause the instrument number to disappear.
    Methods 3 and 4: The above two methods using a OpenMPT module (.mptm format). The results should be the same as with the IT format.
Saga Musix

Saga Musix

2012-11-13 14:18

administrator   ~0000930

Your stories about RAIDs and tablets are irrelevant. Please refrain from posting useless things on the issue tracker. It is neither funny nor would anyone care.

The bug you describe should be fixed in the current test version, please try the link in my first comment.

Really Weird Person

Really Weird Person

2012-11-13 22:28

reporter   ~0000931

The bug is fixed indeed.

Issue History

Date Modified Username Field Change
2011-03-19 09:52 Really Weird Person New Issue
2012-07-13 12:59 Saga Musix Relationship added related to 0000030
2012-10-21 15:30 Saga Musix Note Added: 0000913
2012-10-21 15:30 Saga Musix Assigned To => Saga Musix
2012-10-21 15:30 Saga Musix Status new => feedback
2012-11-11 16:48 Saga Musix Note Added: 0000925
2012-11-11 22:42 Really Weird Person Note Added: 0000929
2012-11-11 22:42 Really Weird Person Status feedback => assigned
2012-11-11 22:43 Really Weird Person Note Edited: 0000929 View Revisions
2012-11-11 22:46 Really Weird Person Note Edited: 0000929 View Revisions
2012-11-11 22:47 Really Weird Person Note Edited: 0000929 View Revisions
2012-11-13 11:05 Really Weird Person Note Edited: 0000929 View Revisions
2012-11-13 14:18 Saga Musix Note Added: 0000930
2012-11-13 22:28 Really Weird Person Note Added: 0000931
2012-11-13 22:33 Saga Musix Status assigned => resolved
2012-11-13 22:33 Saga Musix Resolution open => fixed
2012-11-13 22:33 Saga Musix Fixed in Version => OpenMPT 1.20.04.00 (upgrade first)
2012-11-13 22:33 Saga Musix Target Version => OpenMPT 1.20.04.00 (upgrade first)