View Issue Details

IDProjectCategoryView StatusLast Update
0000030OpenMPT[All Projects] Feature Requestpublic2012-11-13 23:13
ReporterrakibAssigned ToSaga Musix 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
PlatformWindowsOS7OS VersionUltimate
Product VersionOpenMPT 1.19.00.* (old testing) 
Target VersionOpenMPT 1.20.04.00 (upgrade first)Fixed in VersionOpenMPT 1.20.04.00 (upgrade first) 
Summary0000030: Be able to change the order of a sample or instrument number
Description

It could be useful to be able to move a sample from e.g number 1 to 3 without any problems with the instrument assignment and vise versa. I think under the comments tab could be the best place to do the switches.

TagsNo tags attached.
Has the bug occurred in previous versions?No
Tested code revision (in case you know it)

Relationships

related to 0000087 closed Sort Samples and Instruments 
related to 0000088 resolvedSaga Musix Add Samples and Instruments Before or After Current Sample or Instrument 

Activities

Saga Musix

Saga Musix

2011-08-04 23:31

administrator   ~0000315

I'll probably implement this in the treeview, because all the drag&drop code is already present there.

Saga Musix

Saga Musix

2012-10-21 15:30

administrator   ~0000912

Here's something to try... From the treeview, it is now possible to rearrange samples and instruments using drag&drop, and you can also insert and duplicate them through the context menu. http://sagagames.de/stuff/mptrack.exe

Saga Musix

Saga Musix

2012-10-28 16:04

administrator   ~0000917

Meh, I already found some bugs in the code. I hate it when that happens one day after a release...

Saga Musix

Saga Musix

2012-11-11 16:48

administrator   ~0000924

Reminder sent to: rakib

So, any comments on whether this works as intended or not?

rakib

rakib

2012-11-11 21:35

reporter   ~0000926

It works but I would like a warning if write overwrite a sample.

Saga Musix

Saga Musix

2012-11-11 21:38

administrator   ~0000927

Last edited: 2012-11-11 21:39

View 2 revisions

If you manage to overwrite samples, that sounds like a bug to me. How did you manage to do that? Are you using the latest test version from above?

rakib

rakib

2012-11-11 22:32

reporter   ~0000928

No I didnt, used 1.20.04.00, will test more tomorrow.

rakib

rakib

2012-11-13 23:12

reporter   ~0000932

Works fine, no problems. Thanks for the update.

Issue History

Date Modified Username Field Change
2010-11-08 13:53 rakib New Issue
2011-08-04 23:31 Saga Musix Assigned To => Saga Musix
2011-08-04 23:31 Saga Musix Status new => assigned
2011-08-04 23:31 Saga Musix Note Added: 0000315
2011-08-04 23:31 Saga Musix Target Version => OpenMPT 1.20.01.00 (upgrade first)
2012-05-05 16:50 Saga Musix Target Version OpenMPT 1.20.01.00 (upgrade first) => OpenMPT 1.20.02.00 (upgrade first)
2012-07-04 00:40 Saga Musix Relationship added related to 0000087
2012-07-13 12:59 Saga Musix Relationship added related to 0000088
2012-10-14 11:16 Saga Musix Target Version OpenMPT 1.20.02.00 (upgrade first) => OpenMPT 1.20.04.00 (upgrade first)
2012-10-21 15:30 Saga Musix Note Added: 0000912
2012-10-21 15:30 Saga Musix Status assigned => feedback
2012-10-28 16:04 Saga Musix Note Added: 0000917
2012-11-11 16:48 Saga Musix Note Added: 0000924
2012-11-11 21:35 rakib Note Added: 0000926
2012-11-11 21:35 rakib Status feedback => assigned
2012-11-11 21:38 Saga Musix Note Added: 0000927
2012-11-11 21:39 Saga Musix Status assigned => feedback
2012-11-11 21:39 Saga Musix Note Edited: 0000927 View Revisions
2012-11-11 22:32 rakib Note Added: 0000928
2012-11-11 22:32 rakib Status feedback => assigned
2012-11-13 22:33 Saga Musix Status assigned => feedback
2012-11-13 23:12 rakib Note Added: 0000932
2012-11-13 23:12 rakib Status feedback => assigned
2012-11-13 23:13 Saga Musix Status assigned => resolved
2012-11-13 23:13 Saga Musix Resolution open => fixed
2012-11-13 23:13 Saga Musix Fixed in Version => OpenMPT 1.20.04.00 (upgrade first)