View Issue Details

IDProjectCategoryView StatusLast Update
0000118OpenMPT[All Projects] Generalpublic2011-05-31 18:06
Reporter404notfoundAssigned ToSaga Musix 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product VersionOpenMPT 1.19.01.00 (upgrade first) 
Target VersionOpenMPT 1.19.02.00 (upgrade first)Fixed in VersionOpenMPT 1.19.02.00 (upgrade first) 
Summary0000118: "lost" sampledata in protracker.
Description

Attached tune was created in v1.19.01.03. Oddly, samples don't seem to load in Xmplay and (I believe) Milky tracker.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

404notfound

404notfound

2011-04-21 23:36

reporter  

flynn89_v02.zip (95,797 bytes)
404notfound

404notfound

2011-04-22 00:18

reporter   ~0000158

Exporting the tune in compatibility mode doesn't do much justice either. Neither did converting it to screamtracker and back to protracker.

Saga Musix

Saga Musix

2011-04-22 08:58

administrator   ~0000159

Can't check at the moment but I am 99% sure that it happens because of the separator pattern you have used in this MOD. You cannot use separator patterns in MOD files, but OpenMPT doesn't prevent you from doing so for some reason. The problem is that other applications rightfully interpret the separator as a pattern number, and try to load this pattern in the sample data area, so there's nothing left to load for the sample loader.

404notfound

404notfound

2011-04-22 10:26

reporter   ~0000160

Confirming suspicion.

Saga Musix

Saga Musix

2011-04-29 21:32

administrator   ~0000175

Ok, starting from revision 860, separator patterns are not allowed in MOD files anymore.

Saga Musix

Saga Musix

2011-05-03 21:08

administrator   ~0000181

Please check if http://sagagames.de/stuff/mptrack.exe fixes the problem for you.

404notfound

404notfound

2011-05-03 22:04

reporter   ~0000183

I am confirming the fix, however, there's another slight problem.
If resaving mod with separator pattern in the new revision, all patterns after separator get lost. Patterns above max number get nuked.

Saga Musix

Saga Musix

2011-05-03 22:15

administrator   ~0000185

Last edited: 2011-05-03 22:17

View 2 revisions

I'll add a warning on save in the next version... (or just change the save mechanism in another way)

Saga Musix

Saga Musix

2011-05-04 20:34

administrator   ~0000188

Ok, please check if the MOD saving behaviour is better now (same URL).

404notfound

404notfound

2011-05-04 21:20

reporter   ~0000189

Confirmed.

Issue History

Date Modified Username Field Change
2011-04-21 23:36 404notfound New Issue
2011-04-21 23:36 404notfound File Added: flynn89_v02.zip
2011-04-22 00:18 404notfound Note Added: 0000158
2011-04-22 08:58 Saga Musix Note Added: 0000159
2011-04-22 10:26 404notfound Note Added: 0000160
2011-04-29 21:32 Saga Musix Note Added: 0000175
2011-05-02 16:49 Saga Musix Assigned To => Saga Musix
2011-05-02 16:49 Saga Musix Status new => assigned
2011-05-03 21:08 Saga Musix Note Added: 0000181
2011-05-03 21:08 Saga Musix Status assigned => feedback
2011-05-03 22:04 404notfound Note Added: 0000183
2011-05-03 22:04 404notfound Status feedback => assigned
2011-05-03 22:15 Saga Musix Note Added: 0000185
2011-05-03 22:17 Saga Musix Note Edited: 0000185 View Revisions
2011-05-04 20:34 Saga Musix Note Added: 0000188
2011-05-04 20:34 Saga Musix Status assigned => feedback
2011-05-04 21:20 404notfound Note Added: 0000189
2011-05-04 21:20 404notfound Status feedback => assigned
2011-05-04 21:21 Saga Musix Status assigned => resolved
2011-05-04 21:21 Saga Musix Fixed in Version => OpenMPT 1.19.01.* (old testing)
2011-05-04 21:21 Saga Musix Resolution open => fixed
2011-05-31 18:06 Saga Musix Target Version => OpenMPT 1.19.02.00 (upgrade first)