View Issue Details

IDProjectCategoryView StatusLast Update
0001580OpenMPTBuild Systempublic2022-03-15 08:38
Reporterfunute Assigned Tomanx  
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformwine-7.4OSArch LinuxOS VersionLinux 5.16.14
Product VersionOpenMPT 1.30.03.00 / libopenmpt 0.6.2 (upgrade first) 
Target VersionOpenMPT 1.30.04.00 / libopenmpt 0.6.3 (current stable)Fixed in VersionOpenMPT 1.30.04.00 / libopenmpt 0.6.3 (current stable) 
Summary0001580: OpenMPT Wine integration build script fails to compile (again)
Description

Similar to https://bugs.openmpt.org/view.php?id=1210, when Wine integration is enabled in the settings, the build script that runs on startup is erroring out with:

misc/mptOS.cpp: In function ‘mpt::mptx::osinfo::windows::Version OpenMPT::mpt::OS::Windows::Version::GetMinimumAPILevel()’:
misc/mptOS.cpp:172:54: error: ‘constexpr mpt::mptx::osinfo::windows::Version::Version()’ is private within this context
  172 |                 return mpt::osinfo::windows::Version();
      |                                                      ^
In file included from misc/mptOS.h:17,
                 from misc/mptOS.cpp:12:
src/mpt/osinfo/windows_version.hpp:101:19: note: declared private here
  101 |         constexpr Version() noexcept
      |                   ^~~~~~~
make: *** [build/wine/native_support.mk:208: misc/mptOS.o] Error 1
make: *** Waiting for unfinished jobs....
Steps To Reproduce
  1. Enable Wine integration via OpenMPT Setup > Wine > Check "Enable Wine native host support (requires restarting OpenMPT)"
  2. Restart OpenMPT
Additional Information

r16800 looks like a possible culprit: https://source.openmpt.org/browse/openmpt/trunk/?op=revision&rev=16800&peg=16800

TagsNo tags attached.
Has the bug occurred in previous versions?No
Tested code revision (in case you know it)

Activities

manx

manx

2022-03-15 08:38

administrator   ~0005137

Should be fixed in r17128 (1.31) and r17129 (1.30).

You can either update to a 1.30.03.02 test build, or extract https://manx.datengang.de/openmpt/OpenMPT-1.30.03.00-hotfix-wine-integration.zip over your OpenMPT install directory.

Issue History

Date Modified Username Field Change
2022-03-15 00:45 funute New Issue
2022-03-15 07:49 manx Assigned To => manx
2022-03-15 07:49 manx Status new => assigned
2022-03-15 07:50 manx Target Version => OpenMPT 1.30.04.00 / libopenmpt 0.6.3 (current stable)
2022-03-15 08:38 manx Status assigned => resolved
2022-03-15 08:38 manx Resolution open => fixed
2022-03-15 08:38 manx Fixed in Version => OpenMPT 1.30.04.00 / libopenmpt 0.6.3 (current stable)
2022-03-15 08:38 manx Note Added: 0005137