View Issue Details

IDProjectCategoryView StatusLast Update
0000998OpenMPT[All Projects] User Interfacepublic2018-12-16 16:53
ReporterSaga MusixAssigned To 
PrioritynormalSeverityminorReproducibilityunable to reproduce
Status resolvedResolutionfixed 
Product VersionOpenMPT 1.27.00.* (old testing) 
Target VersionFixed in VersionOpenMPT 1.27.10.00 / libopenmpt 0.3.12 (upgrade first) 
Summary0000998: Broken scrolling with touchpad
Description

chocosaurus reported on IRC that scrolling doesn't work with his touchpad; the scrollbars do move but the pattern position is not actually modified: https://www.youtube.com/watch?v=gOTYRisoExo
It might be the case that we are not handling some scroll message (but I cannot see any WM_* message that would be required to be handled and that is missing).

TagsNo tags attached.
Has the bug occurred in previous versions?yes
Tested code revision (in case you know it)

Activities

chocosaurus

chocosaurus

2017-07-31 22:42

reporter  

spyxx_message_log.zip (7,775 bytes)
chocosaurus

chocosaurus

2017-07-31 22:42

reporter   ~0003126

here is the message log from spy++

Saga Musix

Saga Musix

2017-07-31 23:58

administrator   ~0003127

So far those messages look innocent (different from what my trackpad sends but should still be understood by OpenMPT). We also verified that this was broken pre-1.23 when the MFC workarounds for 32-bit scrollbar positions were added.

Saga Musix

Saga Musix

2017-08-11 19:22

administrator   ~0003161

Tried it on another touchpad and it also just worked there. Maybe it would be good to know which touchpad driver you use; is it a Synaptics driver?

chocosaurus

chocosaurus

2017-08-13 18:23

reporter   ~0003164

as far as i can tell i'm just using microsoft default "HID-compliant touch pad" driver - can't see any manufacturer drivers anywhere in device manager - am i checking the right place?

Saga Musix

Saga Musix

2017-08-13 18:29

administrator   ~0003165

Yeah, that sounds like it's just the default driver then, thanks. Maybe that helps with reproducing the issue, we'll see.

Saga Musix

Saga Musix

2018-12-15 22:35

administrator   ~0003756

I just remembered this issue - I had the same problem with the touchscreen driver on my laptop a few months ago. Windows 8 / 10 translates touch events into a sequence of scroll messages that MFC is incapable of handling properly. Rather than re-implementing the whole scrolling business myself, I chose to implement touch gesture support and translate pan gestures into the desired scroll actions. Since modern touchpads typically support various touch gestures, maybe the same fix works for you.

Can you confirm if you can still reproduce the bug with the current OpenMPT version?

chocosaurus

chocosaurus

2018-12-16 01:54

reporter   ~0003757

Works fine now :) Thank you!

Saga Musix

Saga Musix

2018-12-16 10:29

administrator   ~0003758

Great :) So it was really caused by the touch gesture to mouse event translation layer in Windows 10 then.

Issue History

Date Modified Username Field Change
2017-07-31 22:30 Saga Musix New Issue
2017-07-31 22:42 chocosaurus File Added: spyxx_message_log.zip
2017-07-31 22:42 chocosaurus Note Added: 0003126
2017-07-31 23:58 Saga Musix Note Added: 0003127
2017-07-31 23:58 Saga Musix Description Updated View Revisions
2017-07-31 23:58 Saga Musix Has the bug occurred in previous versions? => yes
2017-08-11 19:22 Saga Musix Note Added: 0003161
2017-08-13 18:23 chocosaurus Note Added: 0003164
2017-08-13 18:29 Saga Musix Note Added: 0003165
2018-12-15 22:35 Saga Musix Note Added: 0003756
2018-12-15 22:36 Saga Musix Status new => feedback
2018-12-16 01:54 chocosaurus Note Added: 0003757
2018-12-16 10:29 Saga Musix Status feedback => resolved
2018-12-16 10:29 Saga Musix Resolution open => fixed
2018-12-16 10:29 Saga Musix Fixed in Version => OpenMPT 1.27.10.00 / libopenmpt 0.3.12 (upgrade first)
2018-12-16 10:29 Saga Musix Note Added: 0003758