View Issue Details

IDProjectCategoryView StatusLast Update
0000964OpenMPT[All Projects] User Interfacepublic2017-06-05 13:26
ReporterZerroDeNullAssigned ToSaga Musix 
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSWindowsOS VersionVista
Product VersionOpenMPT 1.27.00.* (old testing) 
Target VersionOpenMPT 1.27.01.00 / libopenmpt 0.3.1 (upgrade first)Fixed in VersionOpenMPT 1.27.01.00 / libopenmpt 0.3.1 (upgrade first) 
Summary0000964: Windows Keyboard Contextmenu Key missing in Tree View
Description

On some Keyboards for Windows PC is a special Key to bring up the Context menu.
In the Tree View when i click and select a sample and then press the Contextmenu Key, nothing happens.
When some thing is selected and the Context Menu Key on the Keyboard gets pressed the according Contextmenu should pop up if there is a Contextmenu avibal for the selected thing.
I would like to tab on a sample press the Contextmenu Key and move with some arrows to the Duplicate Sample command, and then press enter.

Steps To Reproduce

Open ompt file
Create Sample 1
Open tree view
Open Samples Folder in Tree View
Select a Sample
Press Contextmenu-Key on WindowsKeyboard with Windows-Keys as Windows-Startmenu-Key and Contextmenu-Key.
Nothing happens now
A Contextmenu should open
but there is no contextmenu poping up
if i rightclick on the sample with the mouse the contextmenu appears as normal.

Additional Information

I think this is a bug because in most applications a user expect this to work, just because a contextmenukey should bring up a contextmenu.

Any way, thanks for all your great work on this great Open Mod Plug.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2017-06-05 13:26

administrator   ~0003045

Good catch. Application key handling has been implemented for the tree view, as well as pattern, sample and instrument editors (if the key is not already used as a shortcut for something else). r8277 implements this and can be downloaded soon from https://builds.openmpt.org/builds/

Issue History

Date Modified Username Field Change
2017-06-05 03:44 ZerroDeNull New Issue
2017-06-05 13:15 Saga Musix Assigned To => Saga Musix
2017-06-05 13:15 Saga Musix Status new => assigned
2017-06-05 13:26 Saga Musix Status assigned => resolved
2017-06-05 13:26 Saga Musix Resolution open => fixed
2017-06-05 13:26 Saga Musix Fixed in Version => OpenMPT 1.27.01.00 / libopenmpt 0.3.1 (upgrade first)
2017-06-05 13:26 Saga Musix Target Version => OpenMPT 1.27.01.00 / libopenmpt 0.3.1 (upgrade first)
2017-06-05 13:26 Saga Musix Note Added: 0003045