View Issue Details

IDProjectCategoryView StatusLast Update
0000943OpenMPT[All Projects] Generalpublic2017-05-16 11:01
ReporterDrillimationAssigned To 
PrioritynormalSeverityminorReproducibilityrandom
Status closedResolutionunable to reproduce 
Platformx64OSWindowsOS Version7
Product VersionOpenMPT 1.26.09.00 / libopenmpt 0.2-beta22 (upgrade first) 
Target VersionFixed in Version 
Summary0000943: OpenMPT freezing at random on Windows 7
Description

When attempting to open and/or save a file in OpenMPT, the program randomly freezes (and can sometimes crash).

Steps To Reproduce

This happens randomly. Try it with any module. I'm assuming that it wouldn't work with your system.

TagsNo tags attached.
Has the bug occurred in previous versions?Yes
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2017-04-20 12:00

administrator   ~0002977

Please provide the .dmp files associated with those crashes. You can find them in the path shown in the error message presented during a crash, with is a subfolder of %TEMP%\OpenMPT Crash Files.

Drillimation

Drillimation

2017-04-20 12:14

reporter   ~0002978

I haven't experienced a crash yet, I mentioned "crash" if just in case it does for me.

Saga Musix

Saga Musix

2017-04-20 12:17

administrator   ~0002979

In that case, please provide a memory dump for a freeze.
To do so, follow the instructions in the FAQ: https://wiki.openmpt.org/Manual:_Frequently_Asked_Questions#OpenMPT_crashed_but_did_not_create_a_memory_dump
Please take care of the 64-bit instructions there, otherwise I cannot use the memory dump for analyzing the problem.
The resulting .dmp file will be rather big, but can be easily compressed using 7-zip and then hosted somewhere (not on the issue tracker, though, still too big for that).

Saga Musix

Saga Musix

2017-04-23 17:03

administrator   ~0002982

Without a memory dump of the freeze we cannot really help you. Please also describe how you load/save the modules, e.g. do you use the open/save file dialog to do so, or other means such as drag&drop?

Saga Musix

Saga Musix

2017-05-15 20:13

administrator   ~0003026

Last edited: 2017-05-15 20:13

View 2 revisions

Sorry, but if you do not provide the crash or hang dump, there is nothing we can do about this but assume that it's a duplicate of 0000951, which will be addressed in an update very soon.

Issue History

Date Modified Username Field Change
2017-04-20 11:46 Drillimation New Issue
2017-04-20 12:00 Saga Musix Note Added: 0002977
2017-04-20 12:14 Drillimation Note Added: 0002978
2017-04-20 12:17 Saga Musix Note Added: 0002979
2017-04-23 17:03 Saga Musix Note Added: 0002982
2017-05-15 20:13 Saga Musix Status new => closed
2017-05-15 20:13 Saga Musix Resolution open => unable to reproduce
2017-05-15 20:13 Saga Musix Note Added: 0003026
2017-05-15 20:13 Saga Musix Note Edited: 0003026 View Revisions