View Issue Details

IDProjectCategoryView StatusLast Update
0000919OpenMPT[All Projects] Generalpublic2017-02-12 20:25
Reporterpigdevil2010 
Assigned To 
PrioritynormalSeveritymajorReproducibilitysometimes
Status closedResolutionno change required 
Platformx64OSWindowsOS Version10
Product VersionOpenMPT 1.27.00.* (current testing) 
Target VersionFixed in Version 
Summary0000919: MIDI export is broken
Description

Continuing from Issue 916, where I forgot to give an example of a broken midi export and you seems to renamed and fixed it as arpeggio problem. However, the hold notes problem are still not fixed and I got an example of a broken export.

  1. Get Rose by 4-Mat (https://modarchive.org/index.php?request=view_by_moduleid&query=157314)
  2. Export to midi with this configuration (All of them (except percussions) use Melodic (any) channel configuration):

01: 080: Ocarina
02: 080: Ocarina
03: 080: Ocarina
04: 080: Ocarina
05: 082: Lead 2 (sawtooth)
06: 082: Lead 2 (sawtooth)
07: 082: Lead 2 (sawtooth)
08: 082: Lead 2 (sawtooth)
09: 082: Lead 2 (sawtooth)
10: 36 (C-3): Bass Drum 1
11: 42 (F#3): Closed Hi-hat
13: 001: Acoustic Grand Piano
14: 40 (E-3): Electric Snare
15: 081: Lead 1 (square)
16: 081: Lead 1 (square)
17: 081: Lead 1 (square)
18: 081: Lead 1 (square)
19: 36 (C-3): Bass Drum 1
20: 088: Lead 8 (bass + lead)
21: 088: Lead 8 (bass + lead)
22: 082: Lead 2 (sawtooth)
24: 088: Lead 8 (bass + lead)
25: 088: Lead 8 (bass + lead)
26: 082: Lead 2 (sawtooth)
27: 082: Lead 2 (sawtooth)
28: 081: Lead 1 (square)
29: 081: Lead 1 (square)
30: 081: Lead 1 (square)
31: 44 (G#3): Pedal Hi-hat
32: 123: Seashore

3: The resulting midi is a mess of hold notes and non-stop retrigger drums.

(This can be avoided by not having an instrument change in the same tracker channel but it would be nice to see this handled properly.)

TagsNo tags attached.
Has the bug occurred in previous versions?

Yes, since like 1.25

Tested code revision (in case you know it)

7588

Relationships

Activities

Saga Musix

Saga Musix

2017-02-12 20:25

administrator   ~0002879

This is also documented and intended behaviour. OpenMPT is not a MOD to MIDI converter. MIDI export (as clearly written in the manual) is intended as a means of e.g. creating remixing stems, not to produce listenable MIDI files. As such, we expect that the user will be loading each exported MIDI track into a separate channel of their DAW in which they want to continue with editing the MIDI file.
By setting all instruments to "any channel", they all share the same MIDI channels and as such they will overlap. When separating the MIDI file into seperate tracks, this is not an issue.

Issue History

Date Modified Username Field Change
2017-02-12 18:50 pigdevil2010 New Issue
2017-02-12 20:25 Saga Musix Status new => closed
2017-02-12 20:25 Saga Musix Resolution open => no change required
2017-02-12 20:25 Saga Musix Note Added: 0002879