View Issue Details

IDProjectCategoryView StatusLast Update
0000792OpenMPT[All Projects] Playback Compatibilitypublic2016-05-14 00:30
ReporterjanglerAssigned ToSaga Musix 
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version7
Product VersionOpenMPT 1.25.04.00 / libopenmpt 0.2-beta16 (upgrade first) 
Target VersionOpenMPT 1.26.01.00 / libopenmpt 0.2-beta17 (upgrade first)Fixed in VersionOpenMPT 1.26.01.00 / libopenmpt 0.2-beta17 (upgrade first) 
Summary0000792: Overlapping global volume / global volume slide effects handled incorrectly
Description

This is another one from the schismtracker.org "play abuse tests" suite that OpenMPT 1.18.02.00 was marked as passing, but the current version fails the test.

See https://github.com/jangler/schismtracker/wiki/Player-abuse-tests#global-volume for more information. (I didn't write that text—it was ported from the now-offline schismtracker.org wiki).

Steps To Reproduce

Play the attached IT module in Impulse Tracker v2.14, then in OpenMPT.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

jangler

jangler

2016-05-13 23:51

reporter  

global-volume.zip (357 bytes)
Saga Musix

Saga Musix

2016-05-13 23:58

administrator   ~0002371

Funnily enough, 1.18.03 was the last version to do this right... weird.

jangler

jangler

2016-05-14 00:25

reporter   ~0002372

Last edited: 2016-05-14 00:26

View 3 revisions

Interestingly, the latest Schism version from Storlek's Bitbucket also fails two tests that Schism didn't fail back in 2009 when the tests were first administered. We've fixed those now, except for something that could be described as the four-dimensional equivalent of a corner case (the first note of test 25, which OpenMPT also plays incompatibly but isn't even worth reporting).

Saga Musix

Saga Musix

2016-05-14 00:28

administrator   ~0002374

Last edited: 2016-05-14 00:30

View 2 revisions

I know about test case 25, it isn't really worth fixing at this point since it means rearranging a lot of code (which would then be handling other formats incorrectly).
Player routines constantly change so it's no wonder if some supposedly fixed tests suddenly fail again. I want to introduce a regression framework to automatically catch such errors in OpenMPT, but it's not there yet.

Anyway, fixed in r6362.

Issue History

Date Modified Username Field Change
2016-05-13 23:51 jangler New Issue
2016-05-13 23:51 jangler File Added: global-volume.zip
2016-05-13 23:57 Saga Musix Assigned To => Saga Musix
2016-05-13 23:57 Saga Musix Status new => assigned
2016-05-13 23:58 Saga Musix Note Added: 0002371
2016-05-14 00:25 jangler Note Added: 0002372
2016-05-14 00:25 jangler Note Edited: 0002372 View Revisions
2016-05-14 00:26 jangler Note Edited: 0002372 View Revisions
2016-05-14 00:28 Saga Musix Note Added: 0002374
2016-05-14 00:29 Saga Musix Status assigned => resolved
2016-05-14 00:29 Saga Musix Resolution open => fixed
2016-05-14 00:30 Saga Musix Note Edited: 0002374 View Revisions
2016-05-14 00:30 Saga Musix Fixed in Version => OpenMPT 1.26.01.00 / libopenmpt 0.2-beta17 (upgrade first)
2016-05-14 00:30 Saga Musix Target Version => OpenMPT 1.26.01.00 / libopenmpt 0.2-beta17 (upgrade first)