View Issue Details

IDProjectCategoryView StatusLast Update
0000667OpenMPT[All Projects] Feature Requestpublic2017-06-08 20:42
ReporterLPChipAssigned ToSaga Musix 
PrioritylowSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version7
Product Version 
Target VersionOpenMPT 1.27.01.00 (upcoming stable)Fixed in VersionOpenMPT 1.27.01.00 (upcoming stable) 
Summary0000667: Follow song off when clicking inside pattern
Description

If you play the song with follow-song on, and you click somewhere in the pattern, the cursor jumps there then immediately is snapped back to the playing cursor.

I tend to forget this, so I start entering data and it enters it at the wrong place. So I'd like an option to automatically disable follow song when I click inside the pattern to move the cursor to that location. Could possibly also be triggered with the up and down arrow (the rest not obviously)

Steps To Reproduce

Check the Follow Song option, start playing, then click anywhere in the pattern.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

harbinger

harbinger

2015-03-17 00:40

reporter   ~0002004

Oh, I like this idea! I think it's pretty universal that if the user is clicking in the pattern during playback, he probably needs to edit. So Follow Playback can be turned off. Maybe an extra option would also set the Loop Pattern ON so that playback stays in the pattern while he edits.

The only time that I've ever needed Follow Playback to stay on is when I'm checking what a certain Command is (such as SA3 or X11) in the fourth column of a particular channel. Perhaps we can have an override like Alt to NOT turn off Follow Playback when we click in the PE.

Saga Musix

Saga Musix

2015-03-17 00:53

administrator   ~0002005

Last edited: 2015-03-17 00:54

View 2 revisions

I think it's pretty universal that if the user is clicking in the pattern during playback, he probably needs to edit.

I don't. If I ever want to edit a pattern, I stop playback (or I live-record).
So if this is ever going to see the light of day, it's going to be through a (hidden) option.

Amaroq_Dricaldari

Amaroq_Dricaldari

2015-03-18 16:43

reporter   ~0002009

Why would it have to be a hidden option?

Saga Musix

Saga Musix

2015-03-18 16:45

administrator   ~0002010

Because the options dialog is already crammed with options. These kind of behavioral options that only affect a small number of people are best left out of the interface, unless you want to confuse absolutely everyone.

ZerroDeNull

ZerroDeNull

2017-06-07 01:58

reporter   ~0003051

why dont you listen the track and if you like you uncheck the follow song checkbox?
this will stop following instantly and you will stick where you hit the checkbox then you can edit there while the song is still playing on and on

LPChip

LPChip

2017-06-07 10:15

manager   ~0003053

The problem is that I forget that follow song is turned on. If I didn't forget about it, I would not even need this feature request. I'm a man of habits. Most of the time I work on auto pilot to work faster than most people. I'm already entering notes in my mind before I pressed a key in the keyboard, so when I do type them in, I completely have forgotten to check about the follow song option.

As a result of this just happening too often, I've stopped using the follow song option most of the time.

Saga Musix

Saga Musix

2017-06-07 22:11

administrator   ~0003056

Starting from r8285 (soon available from https://builds.openmpt.org/builds/), there is an option in the general settings, "Disable Follow Song on click", which should do pretty much exactly this.

LPChip

LPChip

2017-06-08 06:47

manager   ~0003057

Awesome. Can't wait to test this out. I'll test this as soon as I can and let you know. :) Thanks for the efforts.

LPChip

LPChip

2017-06-08 16:54

manager   ~0003061

Confirmed to work like I want it.

One thing I noticed, but for me its not a big deal: If I play a song with follow song on, I then press the stop button to stop the playback, if I then click anywhere in the pattern, the follow song is still stopped even though I am now in edit mode. Although I'm perfectly fine with this behavior, it may be better if this settong only is applied when the song is playing. Its more logical that way.

Anyway, I'm okay if this gets closed.

Saga Musix

Saga Musix

2017-06-08 20:42

administrator   ~0003062

Yes, that would be more reasonable and logical. r8294 fixes this.

Issue History

Date Modified Username Field Change
2015-03-15 20:50 LPChip New Issue
2015-03-17 00:40 harbinger Note Added: 0002004
2015-03-17 00:53 Saga Musix Note Added: 0002005
2015-03-17 00:54 Saga Musix Note Edited: 0002005 View Revisions
2015-03-18 16:43 Amaroq_Dricaldari Note Added: 0002009
2015-03-18 16:45 Saga Musix Note Added: 0002010
2017-06-07 01:58 ZerroDeNull Note Added: 0003051
2017-06-07 10:15 LPChip Note Added: 0003053
2017-06-07 22:10 Saga Musix Assigned To => Saga Musix
2017-06-07 22:10 Saga Musix Status new => assigned
2017-06-07 22:11 Saga Musix Status assigned => new
2017-06-07 22:11 Saga Musix Note Added: 0003056
2017-06-07 22:11 Saga Musix Status new => feedback
2017-06-07 22:11 Saga Musix Target Version => OpenMPT 1.27.01.00 (upcoming stable)
2017-06-08 06:47 LPChip Note Added: 0003057
2017-06-08 06:47 LPChip Status feedback => assigned
2017-06-08 11:06 Saga Musix Status assigned => feedback
2017-06-08 16:54 LPChip Note Added: 0003061
2017-06-08 16:54 LPChip Status feedback => assigned
2017-06-08 20:42 Saga Musix Status assigned => resolved
2017-06-08 20:42 Saga Musix Resolution open => fixed
2017-06-08 20:42 Saga Musix Fixed in Version => OpenMPT 1.27.01.00 (upcoming stable)
2017-06-08 20:42 Saga Musix Note Added: 0003062