View Issue Details

IDProjectCategoryView StatusLast Update
0000522OpenMPT[All Projects] Generalpublic2017-08-10 10:06
ReporterKatieCadetBugReporterAssigned Tomanx 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSMac OS X Mavericks with WineOS Version10.9 / 1.7
Product VersionOpenMPT 1.23.03.00 (upgrade first) 
Target VersionOpenMPT 1.23.04.00 / libopenmpt 0.2-beta5 (upgrade first)Fixed in VersionOpenMPT 1.23.04.00 / libopenmpt 0.2-beta5 (upgrade first) 
Summary0000522: Playback Cursor always jitters when you run it under Wine 1.7
Description

I found a glitch where the playback cursor jitters when you run OpenMPT under Wine 1.7 or later. That is a technical issue to me!

Steps To Reproduce

Run it under Wine 1.7 using Linux or Mac OS X and you should see the playback cursor jittering at a blink of an eye.

Additional Information

Previous Versions such as 1.18.02.00 and later have this bug because it would be nice if it would be compatible with Wine without the playback jittering and stuff!

TagsNo tags attached.
Has the bug occurred in previous versions?Yes, Starting with 1.18.02.00!
Tested code revision (in case you know it)r4039

Relationships

related to 0001003 confirmed Pattern View :: Smoothscrolling enabled :: displays artifacts 

Activities

Saga Musix

Saga Musix

2014-05-06 21:38

administrator   ~0001638

I'm relatively sure that if it has been there in 1.18, it has already been there before since I never really touched that kind of code back then. Wine is dodgy in many ways, I'm not sure if we can do anything about this, and if anyone would know more about it, it would be manx but he cannot work on the code for the following weeks/months. What you can try right now is to play with the latency and period values, and also try the various available driver types (WaveOut, WASAPI, DirectSound, ...) in the Sound Card options.

manx

manx

2014-05-08 13:15

administrator   ~0001651

Can you please check if http://buildbot.openmpt.org/builds/auto/openmpt-win32/openmpt-win32-r4043.7z works without flickering for you?

KatieCadetBugReporter

KatieCadetBugReporter

2014-05-08 19:15

reporter   ~0001655

Yep! It worked! Bug fixed! Thank you manx! Now it correctly works under Wine 1.7 without the jittering and stuff like that! Thanks a lot!

Issue History

Date Modified Username Field Change
2014-05-06 21:33 KatieCadetBugReporter New Issue
2014-05-06 21:38 Saga Musix Note Added: 0001638
2014-05-08 12:29 manx Assigned To => manx
2014-05-08 12:29 manx Status new => assigned
2014-05-08 13:15 manx Note Added: 0001651
2014-05-08 13:15 manx Status assigned => feedback
2014-05-08 19:15 KatieCadetBugReporter Note Added: 0001655
2014-05-08 19:15 KatieCadetBugReporter Status feedback => assigned
2014-05-08 19:52 Saga Musix Status assigned => resolved
2014-05-08 19:52 Saga Musix Resolution open => fixed
2014-05-08 19:52 Saga Musix Fixed in Version => OpenMPT 1.23.04.00 / libopenmpt 0.2-beta5 (upgrade first)
2014-05-08 19:52 Saga Musix Target Version => OpenMPT 1.23.04.00 / libopenmpt 0.2-beta5 (upgrade first)
2017-08-10 10:06 manx Relationship added related to 0001003