View Issue Details

IDProjectCategoryView StatusLast Update
0000462OpenMPT[All Projects] File Format Supportpublic2016-08-26 18:24
ReporterDanHAssigned ToSaga Musix 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version8
Product VersionOpenMPT 1.22.07.* (old testing) 
Target VersionOpenMPT 1.26.05.00 / libopenmpt 0.2-beta20.1 (upgrade first)Fixed in VersionOpenMPT 1.26.05.00 / libopenmpt 0.2-beta20.1 (upgrade first) 
Summary0000462: MIDI Import: channels mashed up regarding drums
Description

If you import a MIDI file the drums are wrongsounding,
and sometimes exchanged with a melody track (playing drums in these instead piano).

Steps To Reproduce

import the attached MIDI and compare to XM created with MID2XM and to IT created with MPT 1.19.04 (all packed with mo3)

Additional Information

i used RealFont_2_1.SF2 which i did last time too,
the same is for other MIDIs like Forrest Gump Theme / featherg.mid, Trainspotting.mid
unfortunately 1.19.04 wont run anymore,
now tested with 1.17.02.53, 1.20.04, 1.21.01, 1.22.05, 1.22.07, 1.22.07.10

TagsNo tags attached.
Has the bug occurred in previous versions?1.17.02.53 works fine, 1.19.04 possibly, 1.20.04 is the first broken i still have (and all since then)
Tested code revision (in case you know it)

Relationships

related to 0000525 closed Improved MIDI Conversions 
related to 0000418 closed MIDI Import makes wrong Events in the Pattern. They are not in time. 
related to 0000124 resolvedSaga Musix Different Result While Converting MIDI to IT 

Activities

DanH

DanH

2013-12-28 12:42

reporter  

Stereoph-Dak.7z (199,962 bytes)
DanH

DanH

2013-12-29 13:11

reporter  

Trainsp.7z (319,555 bytes)
DanH

DanH

2014-02-02 12:00

reporter   ~0001484

Update: managed to reinstall 1.19.04 on my other machine (X64 Win 7 HP on acer Revo). As supposed this is still without the bug.

Saga Musix

Saga Musix

2016-08-10 00:36

administrator   ~0002588

r6840 introduces the long-awaited fixes for MIDI import. It will be up at https://buildbot.openmpt.org/builds/ within the next few hours, so please try it and see if the file sounds satisfactory now.

Issue History

Date Modified Username Field Change
2013-12-28 12:42 DanH New Issue
2013-12-28 12:42 DanH File Added: Stereoph-Dak.7z
2013-12-28 20:35 DanH Summary MIDI Import channels mashed up regarding drums => MIDI Import: channels mashed up regarding drums
2013-12-28 20:35 DanH Additional Information Updated View Revisions
2013-12-29 12:18 DanH Has the bug occurred in previous versions? yes, but don't know since when => Update 1.17.02.53 works fine, 1.20.04 is the first broken i still have (and all since then)
2013-12-29 12:18 DanH Steps to Reproduce Updated View Revisions
2013-12-29 12:18 DanH Additional Information Updated View Revisions
2013-12-29 12:26 DanH Has the bug occurred in previous versions? Update 1.17.02.53 works fine, 1.20.04 is the first broken i still have (and all since then) => 1.17.02.53 works fine, 1.19.04 possibly, 1.20.04 is the first broken i still have (and all since then)
2013-12-29 13:11 DanH File Added: Trainsp.7z
2014-02-02 12:00 DanH Note Added: 0001484
2015-06-26 23:41 Saga Musix Relationship added related to 0000525
2015-06-26 23:41 Saga Musix Relationship added related to 0000418
2015-06-26 23:41 Saga Musix Relationship added related to 0000124
2016-08-10 00:36 Saga Musix Note Added: 0002588
2016-08-10 00:36 Saga Musix Assigned To => Saga Musix
2016-08-10 00:36 Saga Musix Status new => feedback
2016-08-16 23:26 Saga Musix Status feedback => resolved
2016-08-16 23:26 Saga Musix Resolution open => fixed
2016-08-16 23:26 Saga Musix Fixed in Version => OpenMPT 1.27.01.00 / libopenmpt 0.3.1 (upgrade first)
2016-08-16 23:26 Saga Musix Target Version => OpenMPT 1.27.01.00 / libopenmpt 0.3.1 (upgrade first)
2016-08-26 18:24 Saga Musix Fixed in Version OpenMPT 1.27.01.00 / libopenmpt 0.3.1 (upgrade first) => OpenMPT 1.26.05.00 / libopenmpt 0.2-beta20.1 (upgrade first)
2016-08-26 18:24 Saga Musix Target Version OpenMPT 1.27.01.00 / libopenmpt 0.3.1 (upgrade first) => OpenMPT 1.26.05.00 / libopenmpt 0.2-beta20.1 (upgrade first)