View Issue Details

IDProjectCategoryView StatusLast Update
0000011OpenMPT[All Projects] User Interfacepublic2011-06-04 21:28
ReporterLPChipAssigned ToSaga Musix 
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSWindowsOS Version7 x64 ultimate
Product VersionOpenMPT 1.18.03.00 (upgrade first) 
Target VersionOpenMPT 1.19.03.00 (upgrade first)Fixed in VersionOpenMPT 1.19.03.00 (upgrade first) 
Summary0000011: Song doesn't always loop while it should.
Description

When the song reaches its end, it stops instead of jumping to the beginning of the song.

Steps To Reproduce

Select the first row of any pattern, press the button replay pattern and then uncheck loop pattern. Let the song play to the end, and at my pc it stops there. (the next [--] is selected)

Additional Information

It only happens after you start OpenMPT, and if you change the loop checkbox twice in the general tab as addition to these steps, the bug doesn't occur.

It seems to be a problem with the loop checkbox not being initialised properly during songload.

TagsNo tags attached.
Has the bug occurred in previous versions?yes.
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2010-11-06 11:27

administrator   ~0000003

Clarification from my point of view: It does not happen if you just started OpenMPT, but after opening any module. The key to this bug is that you haven't (re)started the song (using F5/F6 for example), but directly started using "play pattern" and similar functions. I can't quite see yet why it happens, though.

Saga Musix

Saga Musix

2011-06-03 20:35

administrator   ~0000210

Revision 889 / OpenMPT 1.19.02.04 (http://sagagames.de/stuff/mptrack.exe) should fix this issue.

LPChip

LPChip

2011-06-04 21:26

manager   ~0000211

Confirmed. This bug seems fixed. :)

Nice, and thanks.

Issue History

Date Modified Username Field Change
2010-11-06 11:20 LPChip New Issue
2010-11-06 11:27 Saga Musix Note Added: 0000003
2010-11-06 11:28 Saga Musix Status new => confirmed
2011-05-31 18:28 Saga Musix Assigned To => Saga Musix
2011-05-31 18:28 Saga Musix Status confirmed => assigned
2011-05-31 18:32 Saga Musix Target Version => OpenMPT 1.19.03.00 (upgrade first)
2011-06-03 20:35 Saga Musix Note Added: 0000210
2011-06-03 20:35 Saga Musix Status assigned => feedback
2011-06-04 21:26 LPChip Note Added: 0000211
2011-06-04 21:26 LPChip Status feedback => assigned
2011-06-04 21:28 Saga Musix Status assigned => resolved
2011-06-04 21:28 Saga Musix Fixed in Version => OpenMPT 1.19.02.* (old testing)
2011-06-04 21:28 Saga Musix Resolution open => fixed