View Issue Details

IDProjectCategoryView StatusLast Update
0001093OpenMPT[All Projects] User Interfacepublic2018-02-24 17:55
ReportergeoffswiftAssigned ToSaga Musix 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx86OSWindowsOS Version10
Product VersionOpenMPT 1.27.05.00 / libopenmpt 0.3.6 (upgrade first) 
Target VersionOpenMPT 1.27.06.00 / libopenmpt 0.3.7 (upgrade first)Fixed in VersionOpenMPT 1.27.06.00 / libopenmpt 0.3.7 (upgrade first) 
Summary0001093: Sample selection stuck when loading a new file
Description

Using the sample editor, if you select a portion of a sample the same selection is applied when loading a new file. This is the case even if the selected range is outside the size of the newly loaded file.

Steps To Reproduce
  1. Go into the sample editor
  2. Load a big sample
  3. Select part of the big sample using the mouse
  4. Load a smaller sample, needs to be smaller than the start of the previously selected range
  5. Try pressing some keys to trigger the sample
  6. Nothing happens. Can't even tell this is due to the range selected on the previous sample because nothing is shown as selected.
Additional Information

It's more apparent what's going on when you load another sample, which the range can be applied to. This is because the selected range is visible.
Perhaps the selection should be reset when loading another sample, or at the very least reset when the range cannot be applied (if the sample is much smaller).

TagsNo tags attached.
Has the bug occurred in previous versions?Yes
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2018-02-24 17:55

administrator   ~0003446

I don't see a problem in keeping the previous selection when replacing a sample, but r9763/r9764 fixes the issue of not sanitizing the selection for previewed notes. Other edit commands already sanitize the selection.

Issue History

Date Modified Username Field Change
2018-02-24 17:40 geoffswift New Issue
2018-02-24 17:55 Saga Musix Note Added: 0003446
2018-02-24 17:55 Saga Musix Assigned To => Saga Musix
2018-02-24 17:55 Saga Musix Status new => assigned
2018-02-24 17:55 Saga Musix Status assigned => resolved
2018-02-24 17:55 Saga Musix Resolution open => fixed
2018-02-24 17:55 Saga Musix Fixed in Version => OpenMPT 1.27.06.00 / libopenmpt 0.3.7 (upgrade first)
2018-02-24 17:55 Saga Musix Target Version => OpenMPT 1.27.06.00 / libopenmpt 0.3.7 (upgrade first)