View Issue Details

IDProjectCategoryView StatusLast Update
0001020OpenMPT[All Projects] User Interfacepublic2017-09-02 19:58
ReporterWoddAssigned To 
PrioritynormalSeverityminorReproducibilityunable to reproduce
Status closedResolutionno change required 
Platformx64OSWindowsOS Version10
Product VersionOpenMPT 1.27.00.* (old testing) 
Target VersionFixed in Version 
Summary0001020: Edit Step Allows Only 0 and MAX_PATTERN_ROWS
Description

I have found that the edit step spin control allows only 2 values, 0 and MAX_PATTERN_ROWS.

Steps To Reproduce
  1. Create a module (or open one from your computer).
  2. Navigate to the Patterns tab.
  3. Click or tap the up arrow in the edit step spin control
TagsNo tags attached.
Has the bug occurred in previous versions?Not that I know of
Tested code revision (in case you know it)8578

Activities

Saga Musix

Saga Musix

2017-09-02 12:45

administrator   ~0003207

Works just fine here, both in VS2015 and VS2017 builds, both Debug and Release, both 32-bit and 64-bit. In the current revision, that is. I am not going to test code from 300 revisions beyond the current one.

Wodd

Wodd

2017-09-02 16:43

reporter   ~0003208

The edit step works with no problems in revision 8852. Although I seldom have that set to values greater than 0, I thought that it was quite odd to see it return only 0 and MAX_PATTERN_ROWS when using the spin buttons or the [up and down] arrow keys.

Issue History

Date Modified Username Field Change
2017-09-02 11:57 Wodd New Issue
2017-09-02 12:45 Saga Musix Note Added: 0003207
2017-09-02 12:46 Saga Musix Reproducibility always => unable to reproduce
2017-09-02 12:46 Saga Musix Status new => feedback
2017-09-02 16:43 Wodd Note Added: 0003208
2017-09-02 16:43 Wodd Status feedback => new
2017-09-02 19:58 Saga Musix Status new => closed
2017-09-02 19:58 Saga Musix Resolution open => no change required