View Issue Details

IDProjectCategoryView StatusLast Update
0001002OpenMPT[All Projects] Generalpublic2017-08-10 16:26
ReporterharbingerAssigned ToSaga Musix 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx86OSWindowsOS VersionXP
Product VersionOpenMPT 1.26.12.00 / libopenmpt 0.2-beta26 (upgrade first) 
Target VersionOpenMPT 1.26.13.00 / libopenmpt 0.2-beta27 (upgrade first)Fixed in VersionOpenMPT 1.26.13.00 / libopenmpt 0.2-beta27 (upgrade first) 
Summary0001002: Amplify not working on default Instrument volumes
Description

When using the Amplify function on default values of Instrument volume, the function assumes 64 as the default value instead of what's in the Global volume field for that Instrument. So when I apply the Amplify function to Instrument-based notes whose default Global volumes are say 32, and i set the Amplify amount to 75%, it sets their volumes to 48 rather than 24.

It seems the Amplify should work on the default volume that the Instrument plays (or there should be an option in the dialog to work off the Global Instrument volume).

Steps To Reproduce
  1. Create a sample-based Instrument.
  2. Set the Global volume of the Instrument to 32.
  3. In the PE, choose the Instrument in the dropdown, and enter a note in a channel. (If you have the "Show Default Volumes" option on, you will see a muted volume text of 32).
  4. Select the note or its channel, and choose the Amplify function.
  5. Set the Amplify amount to 75% (so we can instead play the note at volume 24), and click OK.
  6. The note will now show an entered volume of 48.
TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2017-08-09 23:18

administrator   ~0003130

I suppose you are trying to amplify a plugin-based instrument? For sample-based instruments the current behaviour is correct because global volume is a factor applied on top of volume commands.

Saga Musix

Saga Musix

2017-08-10 00:11

administrator   ~0003131

Plugin-based instruments can now be amplified properly if their global volume is not 64 as of r8733. As a nice side effect, the amplification code is much cleaner too. :)

Issue History

Date Modified Username Field Change
2017-08-09 23:16 harbinger New Issue
2017-08-09 23:18 Saga Musix Note Added: 0003130
2017-08-10 00:11 Saga Musix Assigned To => Saga Musix
2017-08-10 00:11 Saga Musix Status new => resolved
2017-08-10 00:11 Saga Musix Resolution open => fixed
2017-08-10 00:11 Saga Musix Fixed in Version => OpenMPT 1.27.01.00 / libopenmpt 0.3.1 (upgrade first)
2017-08-10 00:11 Saga Musix Target Version => OpenMPT 1.27.01.00 / libopenmpt 0.3.1 (upgrade first)
2017-08-10 00:11 Saga Musix Note Added: 0003131
2017-08-10 16:26 Saga Musix Fixed in Version OpenMPT 1.27.01.00 / libopenmpt 0.3.1 (upgrade first) => OpenMPT 1.26.13.00 / libopenmpt 0.2-beta27 (upgrade first)
2017-08-10 16:26 Saga Musix Target Version OpenMPT 1.27.01.00 / libopenmpt 0.3.1 (upgrade first) => OpenMPT 1.26.13.00 / libopenmpt 0.2-beta27 (upgrade first)