View Issue Details

IDProjectCategoryView StatusLast Update
0000881OpenMPT[All Projects] libopenmptpublic2016-10-01 07:24
ReporterjcowgillAssigned Tomanx 
PrioritynormalSeveritytextReproducibilityN/A
Status resolvedResolutionfixed 
Product VersionOpenMPT 1.27.00.* (old testing) 
Target VersionOpenMPT 1.27.01.00 / libopenmpt 0.3.1 (upgrade first)Fixed in VersionOpenMPT 1.27.01.00 / libopenmpt 0.3.1 (upgrade first) 
Summary0000881: openmpt123 man page has a poor NAME section
Description

I've been doing some Debian packaging for libopenmpt, and I got a lintian warning about the openmpt123 man page NAME section.

Currently it looks like this:
openmpt123 - manual page for openmpt123 v0.2, Copyright (c) 2013-2016 OpenMPT developers <https://lib.openmpt.org/>

  • The copyright notice is redundant (appears at the bottom of the manpage and is also documented elsewhere)
  • "manual page for openmpt123" is useless - if I've managed to read the manpage I already know this

I suggest changing it to something else - maybe:q
openmpt123 - command line module music player based on OpenMPT

In the Debian package I have patched the openmpt123.1 file directly, but in OpenMPT's build system it looks like you'd have to use help2man's name option to do this. Ie add --name='command line module music player based on OpenMPT'

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

manx

manx

2016-10-01 07:24

administrator   ~0002679

I used the more general --include=somefile instead of the explicit --name option.
While at it, I also added proper section headers for the copyright notice as well as the options.
Fixed in r7211, and backported to 0.2 in r7212.

Issue History

Date Modified Username Field Change
2016-09-30 22:50 jcowgill New Issue
2016-10-01 06:20 manx Assigned To => manx
2016-10-01 06:20 manx Status new => assigned
2016-10-01 06:20 manx Target Version => OpenMPT 1.27.01.00 / libopenmpt 0.3.1 (upgrade first)
2016-10-01 07:24 manx Status assigned => resolved
2016-10-01 07:24 manx Resolution open => fixed
2016-10-01 07:24 manx Fixed in Version => OpenMPT 1.27.01.00 / libopenmpt 0.3.1 (upgrade first)
2016-10-01 07:24 manx Note Added: 0002679