View Issue Details

IDProjectCategoryView StatusLast Update
0000847OpenMPT[All Projects] Generalpublic2017-09-02 09:40
ReportermanxAssigned Tomanx 
PrioritynoneSeverityfeatureReproducibilityalways
Status closedResolutionwon't fix 
Product Version 
Target VersionOpenMPT 1.?? (libopenmpt 1.0) (goals)Fixed in Version 
Summary0000847: MSVC Clang/C2 support for libopenmpt
Description

Support Windows builds with MSVC Clang/C2 for <s>OpenMPT and</s> libopenmpt.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Relationships

related to 0000771 resolvedmanx Use synchronous exception handling model in OpenMPT 
related to 0001018 resolvedmanx Remove Clang/C2 support 
related to 0000849 closedmanx MSVC Clang/C2 support 
child of 0000783 new cross-platform OpenMPT 

Activities

manx

manx

2016-08-06 07:33

administrator   ~0002546

OpenMPT itself will be difficult currently, because of MFC.

manx

manx

2017-09-02 09:39

administrator   ~0003205

Clang/C2 is no long-term effort by Microsoft. There is no need to support it.
https://www.reddit.com/r/cpp/comments/6oepq4/making_windows_clang_401_play_nice_with_visual/dkhfar0/

Issue History

Date Modified Username Field Change
2016-08-05 11:50 manx New Issue
2016-08-05 11:51 manx Relationship added child of 0000783
2016-08-05 11:54 manx Relationship added related to 0000771
2016-08-06 07:33 manx Target Version => OpenMPT 1.26.03.03 / libopenmpt 0.2-beta19 (upgrade first)
2016-08-06 07:33 manx Description Updated View Revisions
2016-08-06 07:33 manx Note Added: 0002546
2016-08-06 07:33 manx Assigned To => manx
2016-08-06 07:33 manx Status new => assigned
2016-08-06 07:34 manx Summary MSVC Clang/C2 support => MSVC Clang/C2 support for libopenmpt
2016-08-06 07:36 manx Relationship added related to 0000849
2016-08-07 07:03 manx Target Version OpenMPT 1.26.03.03 / libopenmpt 0.2-beta19 (upgrade first) => OpenMPT 1.27.01.00 / libopenmpt 0.3.1 (upgrade first)
2016-10-15 11:55 manx Target Version OpenMPT 1.27.01.00 / libopenmpt 0.3.1 (upgrade first) => OpenMPT 1.?? (libopenmpt 1.0) (goals)
2017-09-02 09:38 manx Relationship added related to 0001018
2017-09-02 09:39 manx Note Added: 0003205
2017-09-02 09:40 manx Status assigned => closed
2017-09-02 09:40 manx Resolution open => no change required
2017-09-02 09:40 manx Resolution no change required => won't fix