View Issue Details

IDProjectCategoryView StatusLast Update
0001037OpenMPT[All Projects] User Interfacepublic2017-10-02 14:38
ReportermanxAssigned Tomanx 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Platformx86 / x64OSWineOS Version(version plz)
Product VersionOpenMPT 1.27.01.00 / libopenmpt 0.3.1 (upgrade first) 
Target VersionOpenMPT 1.27.02.00 / libopenmpt 0.3.2/0.3.3 (current stable)Fixed in VersionOpenMPT 1.27.02.00 / libopenmpt 0.3.2/0.3.3 (current stable) 
Summary0001037: Dialogs do not allow keyboard input when invoked via a keyboard shortcut
Description

Dialogs do not allow keyboard input when invoked via a keyboard shortcut.
An edit field just does not react to any keyboard input, no character presses, no cursor movement.

Originally reported by hicoleri on IRC.

Steps To Reproduce

Ctrl+Shift+s when an module is open

Additional Information

Happens on any Wine version (tested with 1.6.2 and 2.0.2 and versions in between)

TagsNo tags attached.
Has the bug occurred in previous versions?Yes. 1.25.02.00 works, 1.25.03.00 does not work any more
Tested code revision (in case you know it)

Relationships

related to 0000713 new KeyboardHook can ultimately invoke a message loop which can cause re-entry to the hook function 

Activities

manx

manx

2017-10-02 14:37

administrator   ~0003280

This is caused by a bug in the work-around for 0000713: r5636.

manx

manx

2017-10-02 14:38

administrator   ~0003281

Fixed in r9023 (1.28), r9024 (1.27), r9025 (1.26).

Issue History

Date Modified Username Field Change
2017-10-02 13:44 manx New Issue
2017-10-02 13:44 manx Status new => assigned
2017-10-02 13:44 manx Assigned To => manx
2017-10-02 13:45 manx Relationship added related to 0000713
2017-10-02 14:36 manx Target Version OpenMPT 1.28.01.00 (goals) => OpenMPT 1.27.02.00 / libopenmpt 0.3.2/0.3.3 (current stable)
2017-10-02 14:36 manx Summary File Dialogs do not allow editing the filename when invoked via a keyboard shortcut => Dialogs do not allow keyboard input when invoked via a keyboard shortcut
2017-10-02 14:36 manx Description Updated View Revisions
2017-10-02 14:37 manx Note Added: 0003280
2017-10-02 14:38 manx Status assigned => resolved
2017-10-02 14:38 manx Resolution open => fixed
2017-10-02 14:38 manx Fixed in Version => OpenMPT 1.27.02.00 / libopenmpt 0.3.2/0.3.3 (current stable)
2017-10-02 14:38 manx Note Added: 0003281