View Issue Details

IDProjectCategoryView StatusLast Update
0001195OpenMPT[All Projects] File Format Supportpublic2019-02-23 14:50
ReporterZeroJanitorAssigned ToSaga Musix 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version10
Product VersionOpenMPT 1.28.02.00 / libopenmpt 0.4.1 (upgrade first) 
Target VersionOpenMPT 1.28.03.00 / libopenmpt 0.4.3 (upgrade first)Fixed in VersionOpenMPT 1.28.03.00 / libopenmpt 0.4.3 (upgrade first) 
Summary0001195: MIDI export sometimes assigns instruments to wrong channels and/or detunes at random
Description

When selecting the option to allow instruments to overlap channels, sometimes this causes instruments that are playing to be overwritten by other instruments that come in later in the song. When the overlap option is disabled however, the MIDI will go off-key during random sections. This means that no matter what is done, I cannot achieve an accurate MIDI export.

Steps To Reproduce

This seems to occur primarily with files with instruments that come in later in the song; songs that use the same instrument set from beginning to end do not seem to have this issue. Does not seem to affect percussion instruments.

Additional Information

I would enclose a source file and the MIDI exports with the issue but the uploader does not seem to support these file types.

TagsNo tags attached.
Has the bug occurred in previous versions?Yes
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2019-02-01 20:46

administrator   ~0003838

The "overlap" mode behaves as intended, by the way. It is intended to be used when exporting stems that are then used as individual MIDI tracks in the DAW where they are imported. The rationale is to be able to export more than 16 concurrently playing instruments for this usage mode.

The default mode, however, should behave as most people would imagine and as if all instruments were exported into a single MIDI track. I have now managed to reproduce your issue with the pitch bend based on the description, so there is no more need to upload an example file (you can simply zip or 7z your modules to attach them, by the way).



midi-detune-repro.7z (894 bytes)
Saga Musix

Saga Musix

2019-02-01 21:22

administrator   ~0003839

Last edited: 2019-02-01 22:19

View 2 revisions

r11292 should fix this problem. You can download a test build from here: https://builds.openmpt.org/builds/auto/openmpt/bin.win32/1.28/ (32-bit) or https://builds.openmpt.org/builds/auto/openmpt/bin.win64/1.28/ (64-bit) - it will be available in a few hours at the latest.

Saga Musix

Saga Musix

2019-02-01 23:50

administrator   ~0003840

r11292 is now downloadable from the links above.

Saga Musix

Saga Musix

2019-02-23 14:50

administrator   ~0003856

I have found another small issue when instruments with differing MIDI pitch wheel depth would share the same channel (only a concern when exporting a track that was using instrument plugins, otherwise all instruments use a pitch wheel depth of 12); this will be corrected in the next release.

Issue History

Date Modified Username Field Change
2019-02-01 20:39 ZeroJanitor New Issue
2019-02-01 20:46 Saga Musix File Added: midi-detune-repro.7z
2019-02-01 20:46 Saga Musix Note Added: 0003838
2019-02-01 20:46 Saga Musix Assigned To => Saga Musix
2019-02-01 20:46 Saga Musix Status new => assigned
2019-02-01 20:47 Saga Musix Target Version => OpenMPT 1.28.03.00 / libopenmpt 0.4.3 (upgrade first)
2019-02-01 21:22 Saga Musix Note Added: 0003839
2019-02-01 21:22 Saga Musix Status assigned => feedback
2019-02-01 22:19 Saga Musix Note Edited: 0003839 View Revisions
2019-02-01 23:50 Saga Musix Note Added: 0003840
2019-02-10 21:58 Saga Musix Status feedback => resolved
2019-02-10 21:58 Saga Musix Resolution open => fixed
2019-02-10 21:58 Saga Musix Fixed in Version => OpenMPT 1.28.03.00 / libopenmpt 0.4.3 (upgrade first)
2019-02-23 14:50 Saga Musix Note Added: 0003856