View Issue Details

IDProjectCategoryView StatusLast Update
0000972OpenMPT[All Projects] User Interfacepublic2017-06-12 13:54
ReporterjmkzAssigned ToSaga Musix 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version7
Product VersionOpenMPT 1.27.00.* (current testing) 
Target VersionOpenMPT 1.27.01.00 (upcoming stable)Fixed in VersionOpenMPT 1.27.01.00 (upcoming stable) 
Summary0000972: FontDot does not work against whitespace
Description

As a personal preference, I used to edit the integrated font bitmap to avoid show dots of empty cells. Now with FontDot makes possible avoid to build my own modifications, however, does not work when is used a whitespace.

Steps To Reproduce

Change [Pattern Editor].FontDot value to space character and apply the new setting.

Additional Information

It will be needed change the typography to see the change, but it will not be persistent for a next session or instance.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)8282

Activities

Saga Musix

Saga Musix

2017-06-09 10:00

administrator   ~0003066

Hm, I guess that's because strings read from INI files are automatically trimmed... Maybe we have to hex-encode this setting.

Saga Musix

Saga Musix

2017-06-09 20:27

administrator   ~0003068

r8307 should work around this. Specifying an empty or space DotChar should both use a space for display.

jmkz

jmkz

2017-06-11 16:51

reporter   ~0003071

It's perfect, Thank you!

Issue History

Date Modified Username Field Change
2017-06-09 03:38 jmkz New Issue
2017-06-09 10:00 Saga Musix Note Added: 0003066
2017-06-09 20:26 Saga Musix Assigned To => Saga Musix
2017-06-09 20:26 Saga Musix Status new => assigned
2017-06-09 20:27 Saga Musix Status assigned => new
2017-06-09 20:27 Saga Musix Note Added: 0003068
2017-06-09 20:27 Saga Musix Status new => feedback
2017-06-11 16:51 jmkz Note Added: 0003071
2017-06-11 16:51 jmkz Status feedback => assigned
2017-06-12 13:54 Saga Musix Status assigned => resolved
2017-06-12 13:54 Saga Musix Resolution open => fixed
2017-06-12 13:54 Saga Musix Fixed in Version => OpenMPT 1.27.01.00 (upcoming stable)
2017-06-12 13:54 Saga Musix Target Version => OpenMPT 1.27.01.00 (upcoming stable)