View Issue Details

IDProjectCategoryView StatusLast Update
0000946OpenMPT[All Projects] Plugins / VSTpublic2017-05-04 13:22
ReporterchokoAssigned ToSaga Musix 
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version10
Product VersionOpenMPT 1.26.10.00 / libopenmpt 0.2-beta23 (upgrade stable) 
Target VersionOpenMPT 1.26.11.00 / libopenmpt 0.2-beta24 (current stable)Fixed in VersionOpenMPT 1.26.11.00 / libopenmpt 0.2-beta24 (current stable) 
Summary0000946: Cannot save filter plugin settings
Description

MPT won't save plugin settings for TAL-Filter-2. This is also the case with HY-Reso and a few other filter plugins. I haven't had any problems with other types of plugins. It's only the filter plugins...

Steps To Reproduce

Get the plugin https://tal-software.com/products/tal-filter and change some settings and save the song. The plugin resets.

TagsNo tags attached.
Has the bug occurred in previous versions?yes
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2017-05-01 11:55

administrator   ~0002989

Works just fine here. Are you using the latest version of the plugin?

Saga Musix

Saga Musix

2017-05-01 12:20

administrator   ~0002990

HY-Reso can no longer be downloaded, but TAL-Filter-2 works both in 32-bit and 64-bit flavour here. If a plugin fails to report its parameter state, it is rarely a problem that's exclusive to OpenMPT, so please try if e.g. http://www.hermannseib.com/english/vsthost.htm has the same problem.

choko

choko

2017-05-01 13:49

reporter   ~0002991

Alright, I think you're on the right track. vsthost doesn't save the plugin settings either. I just tried on Windows 7, and it does the same thing. I'm curious how you got it to work.

Saga Musix

Saga Musix

2017-05-01 13:56

administrator   ~0002992

Just to get an idea what the plugin might be doing differently on your systems, can you save the plugin bank in either VSTHost or OpenMPT's plugin editor and attach it to this bug report (zip or 7z the file first)?

choko

choko

2017-05-01 14:09

reporter   ~0002993

An interesting thing I found, I can load the plugin bank and it works correctly! But it would be a pain loading the bank every single time I open my project.



fxb.zip (3,873 bytes)
Saga Musix

Saga Musix

2017-05-01 14:13

administrator   ~0002994

Okay, the fxb file looks as expected, so it would be weird if it could not be loaded after all. Can you create an empty module, put the plugin in there, save it and then upload that module (given that the parameters don't load properly)?

choko

choko

2017-05-01 14:28

reporter   ~0002995

I see that the knobs on the plugin do save, but not the points or lines.



module.zip (764 bytes)
Saga Musix

Saga Musix

2017-05-01 15:37

administrator   ~0002996

Last edited: 2017-05-01 15:55

View 2 revisions

So what is it supposed to look like? When loading that file, I see the envelope of the default preset. Did you customize the envelope?

EDIT: Having a closer look at the module file, it seems like the plugin preset data was not embedded. While that still sounds like a plugin issue more than an OpenMPT issue, maybe we can somehow find out why it doesn't work for you. I'll try to think of some way of doing that.

choko

choko

2017-05-01 16:01

reporter   ~0002997

Yes, I did customize the envelope to a bunch of random points before uploading the file. Thanks for responding to this issue! I hope you can come up with something.

Saga Musix

Saga Musix

2017-05-01 17:14

administrator   ~0002998

Please try this modified build to hopefully get some clues: https://sagagames.de/stuff/mptrack.exe
When saving a module, it should show you a message box containing a few diagnostic messages. Press Ctrl+C while the message box is showing and then paste the contents here.
Since the message will be shown for any VST plugin, it's best to once again try it with a fresh module only containing this plugin.

choko

choko

2017-05-01 17:35

reporter   ~0002999


Open ModPlug Tracker - Error

ProgramsAreChunks() = 1
SaveAllParameters()


OK

Saga Musix

Saga Musix

2017-05-01 17:42

administrator   ~0003000

Okay, now that's an unexpected result... Please download the executable again and do the same thing with the new executable.

choko

choko

2017-05-01 17:49

reporter   ~0003001

ProgramsAreChunks() = 1
effIdentify = 0
effIdentify expected = 4e764566
SaveAllParameters()

Saga Musix

Saga Musix

2017-05-01 18:04

administrator   ~0003002

Okay, I just found out that that I did in fact not download the latest version of TAL-Filter (somehow the colourful platform icons next to the old version downloads caught my eyes more easily than the grey download buttons for the current version...).
I can now confirm that the current version of TAL-Filter returns 0 for effIdentify. This function is deprecated and I guess now the first plugins start not returning the proper value for it anymore. In the next build, I'm going to ignore effIdentify entirely, which should make saving the parameters for this plugin possible again.

Saga Musix

Saga Musix

2017-05-01 18:11

administrator   ~0003003

Fixed in r8120 / OpenMPT 1.27.00.45.

Saga Musix

Saga Musix

2017-05-01 23:16

administrator   ~0003005

You can now find an up-to-date test build that works with TAL-Filter-2 and doesn't show the test message box at https://builds.openmpt.org/builds/auto/openmpt-win64/

Issue History

Date Modified Username Field Change
2017-05-01 01:47 choko New Issue
2017-05-01 02:32 choko Steps to Reproduce Updated View Revisions
2017-05-01 11:55 Saga Musix Note Added: 0002989
2017-05-01 12:20 Saga Musix Note Added: 0002990
2017-05-01 13:49 choko Note Added: 0002991
2017-05-01 13:56 Saga Musix Note Added: 0002992
2017-05-01 14:09 choko File Added: fxb.zip
2017-05-01 14:09 choko Note Added: 0002993
2017-05-01 14:13 Saga Musix Note Added: 0002994
2017-05-01 14:28 choko File Added: module.zip
2017-05-01 14:28 choko Note Added: 0002995
2017-05-01 15:37 Saga Musix Note Added: 0002996
2017-05-01 15:55 Saga Musix Note Edited: 0002996 View Revisions
2017-05-01 16:01 choko Note Added: 0002997
2017-05-01 17:14 Saga Musix Note Added: 0002998
2017-05-01 17:35 choko Note Added: 0002999
2017-05-01 17:42 Saga Musix Note Added: 0003000
2017-05-01 17:49 choko Note Added: 0003001
2017-05-01 18:04 Saga Musix Note Added: 0003002
2017-05-01 18:06 Saga Musix Assigned To => Saga Musix
2017-05-01 18:06 Saga Musix Status new => assigned
2017-05-01 18:11 Saga Musix Status assigned => resolved
2017-05-01 18:11 Saga Musix Resolution open => fixed
2017-05-01 18:11 Saga Musix Fixed in Version => OpenMPT 1.27.01.00 (upcoming stable)
2017-05-01 18:11 Saga Musix Target Version => OpenMPT 1.27.01.00 (upcoming stable)
2017-05-01 18:11 Saga Musix Note Added: 0003003
2017-05-01 23:16 Saga Musix Note Added: 0003005
2017-05-04 13:22 Saga Musix Fixed in Version OpenMPT 1.27.01.00 (upcoming stable) => OpenMPT 1.26.11.00 / libopenmpt 0.2-beta24 (current stable)
2017-05-04 13:22 Saga Musix Target Version OpenMPT 1.27.01.00 (upcoming stable) => OpenMPT 1.26.11.00 / libopenmpt 0.2-beta24 (current stable)