View Issue Details

IDProjectCategoryView StatusLast Update
0000939OpenMPT[All Projects] Feature Requestpublic2017-04-06 10:20
ReporterWoddAssigned To 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionwon't fix 
Platformx64OSWindowsOS Version10
Product VersionOpenMPT 1.26.08.00 / libopenmpt 0.2-beta20.5 (upgrade first) 
Target VersionFixed in Version 
Summary0000939: Retrigger Pattern
Description

Here is a function that would be great to have at my disposal. A retrigger pattern function (similar to the retrigger note function)
It would work similarly to the retrigger note function. But, I envision a function that looks similar to this. RP00 / RP01 (where RP stands for retrigger pattern, of course)
RP00 retriggers the pattern and continues song playback from that row (the equivalent of using the play song from cursor function)
RP01 retriggers the pattern and loops it (the equivalent of using the play pattern from cursor function)
How I envision it working is this.
Position 0, row 0: RP00
Position 10, row 63: B00
In this case, when the song is started, the patterns in positions 0 through 10 will play through and, after row 63 of the pattern in position 10 plays, the song will jump back to row 0 of position 0 and playback occurs as if the user used the play song from cursor function.
Position 0, row 0: RP01
Position 10, row 63: B00
In this case, when the song is started, the patterns in positions 0 through 10 will play through and, after row 63 of the pattern in position 10 plays, the song will jump back to row 0 of position 0 and playback occurs as if the user used the play pattern from cursor function.
The practical case: I have downloaded Rush's 2112 album. In the 2112 suite, there is [url=https://en.wikipedia.org/wiki/Rock_Band_4]what is called a guitar break[/url]. In it, all that is heard is what sounds like water (perhaps from a fountain or a brook) and the lead guitar. I would like to use the retrigger pattern function so that I can make that part loop until it is stopped by the user. But, trying to setup a timed robot or to crop that part out would be tedious. I have tried the robot method with other modules and it generally doesn't work exactly as desired. But, if I had a way to retrigger a given pattern instead of the note, that issue could be eliminated (since OpenMPT synchronously plays samples when using the play pattern from cursor, play song from cursor, or replay pattern function). I had played it for my father to help him go to sleep. But, playing it through the game is tedious because it stops when a controller turns off.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2017-04-06 10:20

administrator   ~0002968

No. Duplicate patterns in the order sequence if you want to repeat them.

Issue History

Date Modified Username Field Change
2017-04-06 10:17 Wodd New Issue
2017-04-06 10:20 Saga Musix Status new => closed
2017-04-06 10:20 Saga Musix Resolution open => won't fix
2017-04-06 10:20 Saga Musix Note Added: 0002968