View Issue Details

IDProjectCategoryView StatusLast Update
0000938OpenMPT[All Projects] Generalpublic2017-08-01 15:09
Reporterpigdevil2010Assigned ToSaga Musix 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version10
Product VersionOpenMPT 1.26.09.00 / libopenmpt 0.2-beta22 (upgrade first) 
Target VersionOpenMPT 1.27.01.00 / libopenmpt 0.3.1 (upgrade first)Fixed in VersionOpenMPT 1.27.01.00 / libopenmpt 0.3.1 (upgrade first) 
Summary0000938: Resampling by insane amount on any methods rather than r8brain crashes OpenMPT
Description

The attached crash files are made by a crash when I resample a sample from 44100Hz to 360Hz with no interpolation.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

pigdevil2010

pigdevil2010

2017-04-04 15:17

reporter  

2017-04-04 22.07.34.zip (324,487 bytes)
Saga Musix

Saga Musix

2017-04-04 15:18

administrator   ~0002960

Before I start investigating, please download a current test build from https://builds.openmpt.org/builds/ because chances are high that this is already fixed by the improved resampler precision in OpenMPT 1.27, which unfortunately cannot be backported to OpenMPT 1.26.

Saga Musix

Saga Musix

2017-04-04 23:07

administrator   ~0002961

Just as I thought, this is caused by the imprecise resamplers in OpenMPT 1.26. Using an OpenMPT 1.27 test build solves the problem.

Issue History

Date Modified Username Field Change
2017-04-04 15:17 pigdevil2010 New Issue
2017-04-04 15:17 pigdevil2010 File Added: 2017-04-04 22.07.34.zip
2017-04-04 15:18 Saga Musix Note Added: 0002960
2017-04-04 23:07 Saga Musix Status new => resolved
2017-04-04 23:07 Saga Musix Resolution open => fixed
2017-04-04 23:07 Saga Musix Fixed in Version => OpenMPT 1.27.01.00 / libopenmpt 0.3.1 (upgrade first)
2017-04-04 23:07 Saga Musix Target Version => OpenMPT 1.27.01.00 / libopenmpt 0.3.1 (upgrade first)
2017-04-04 23:07 Saga Musix Note Added: 0002961
2017-08-01 15:09 Saga Musix Assigned To => Saga Musix